RTC Update Failed

Greetings,
I have installed several kits in the past, but these days I cannot get them to connect. Both the online and the manual methods get the kit to connect to the WiFi (I can ping them) but them I get an RTC fail error:
SCK Connected!!
Wifly Updated.
RTC Update Failed!!
RTC Update Failed!!
With no valid time it's useless to take readings!!

get all:
|1.1-0.9.3-A|00:06:66:35:87:e4|GabrielOffice,a1b2c3d4,0,4|0|60|1|

Is there something wrong from my end or yours?

Thank you,
Kostas

Comments

  • It actually connected and posted data without me changing anything from my side. Looks like it's working fine for the past 12 hours or so.
  • Hi Kostas,
    Viewing your kit serial messages it seems that the problem was obtaining the timestamp from the server. Your kit was successfully connecting to your router but for some reason it was unable to connect to our time server. In this case we recommend first checking if your internet access is working, and resetting your kit.

    This kind of network errors aren't uncommon, but when they appear before updating the RTC time at least one time after boot the firmware doesn't take readings because it doesn't know what time is it and if you post data without a valid timestamp the system won't ingest those readings.
    After the first RTC update if your kit experience temporal network errors they won't become a problem, the kit simply store the readings in eeprom and post them later when the connection is successful.

    regards
    Victor

  • Hi Andre

    The messages that you are seeing when you enter wifly command line (with $$$) about time not set are from wifly's RTC, we don't use that RTC for power reasons.
    Viewing your output it seems that your kit is successfully connecting to your router so the problem seems to be the same that i described in the previous post.
    Is your kit working already?
    if not, simply try resetting and please post your serial port output so we can diagnose your problem.

    regards
    Victor
  • With reset i mean turning off and on your kit or disconnecting it from power and connecting it again.
    The Serial port output is the output of your kit via the serial port, you can get it by connecting your kit to your computer with a USB cable and opening a serial communication software, for example the arduino IDE - Serial Monitor.

    Is your kit working already?

    regards
    Victor
  • Hi Andre

    Sorry i didn't notice before, but looking at you wifly output your problem seems to be with your router DHCP.
    "Assoc=OK" means that your kit is associating with your router but if you look at:
    IP=192.168.0.10:2000
    NM=255.0.0.0
    GW=192.0.0.1
    the netmask and gateway doesn't seem right, and the DHCP:rebind message (http://serverfault.com/questions/870/what-is-dhcp-rebinding) points to a malfunctioning or misconfigured router.
    It looks that this problem is preventing your kit to have access to the internet (and the time server).
    You can try to check your router DHCP server settings or connecting your kit to another network.
    Please keep us posted about your progress.

    regards
    Victor



  • I have the same problem with the RTC time.
    The kit is connected to wifi but cannot get the time reading and thus fails the setup.
    Please can you tell me if there is a manual command to set the time or to ignore this error and continue to conenct my kit?

    ✓ SmartCitizen Ambient Kit 1.1 - "Kickstarter Board"
    ✓ Your kit is running 0.9.4 firmware.
    ✓ This is the latest version.
    ✓ You can skip the firmware update!
    ✓ SCK >> RTC Update Failed!!
    ✓ SCK >> RTC not updated!!!
    ✓ SCK >> With no valid time it's useless to take readings!!
    ✓ SCK >> Trying to get valid time...
    ✓ Your kit is connected to WI-Fi!
Sign In or Register to comment.