Temp & Humidity sensor have spike data read.

edited February 2014 in Sensors
I'm run SCK 1.1 about two day. I found sometime the sensor read the incorrect value. It show above 130 degree. Please see my data below. And is it possible to do a calibration on this sensor? The temperature look lower than it should be.

(http://www.smartcitizen.me/devices/view/796)

Answers

  • edited February 2014
    Hi mangsab! The overshoots in temperature/humidity is a know issue. We are already working on it. Hopefully, it will be fixed for next week. These temperature/humidity readings are sent in RAW to the platform where the algorithms are applied. It seems like sometimes it does the maths wrong.
    Work in progress! :)
  • edited March 2014
    Hi aitoraloa, I see my spike data gone from graph. I think you do some change on coding. But both Temp/Humidity show the same value.

    And what about sensor calibration? This morning i'm got 28 celsius on digital thermometer but on SCK it read only 22.6 celsius. Its alway lower than normal temperature (About 5 celsius)
  • edited March 2014
    Hi mangsab! When we were correcting the spike data error, a variable was repeated in code and this is the reason why during yesterday, the temp/hum readings were showing the same value. It is already solved! :) The temperature sensor reads normally 2 to 4 degrees less than the actual temperature value. The algorithm needs to be reformulated. I will let you know as soon as this is fixed... Best! ;)
  • Thank you aitoraloa. I will wait until the fix come.
  • Any update on reading temperature value problem?
  • Not yet. We will let you know. Dealing with a bigger problem right now. :)
  • edited April 2014
    so, I just received my kit and ran in to several issues. I'll post in the relevant topics. Regarding Temp and Humidity, the graph on the website shows my values stuck at 100% rh and 50 deg C with no variation at all. Is this a bug that still needs to be sorted out ?
    The serial data coming from the SmartCitizen is :
    *******************
    Temperature: 028964 C RAW
    Humidity: 32760 % RAW
    Light: 00000967 lx
    Battery: 100.0 %
    Solar Panel: 00000000 V
    Carbon Monxide: 0000308757 kOhm
    Nitrogen Dioxide: 22.133 kOhm
    Noise: 00000363 mV
    Wifi Spots: 1
    UTC: 2014-4-14 8:06:26
    *******************

    SmartCitizen Device link :
    http://smartcitizen.me/devices/view/1067

    Anool
    Mumbai, India
  • For the calculation of temperature and humidity.
  • Like Anool - same with me. Got mine today and it also reads 100% humidity and 50 deg C
    http://smartcitizen.me/devices/view/1081
  • so this definitely looks like a bug. Are the Dev's looking in to this ?

    Anool
    team @wyolum
    Mumbai, India
  • Hello all,

    we just found a bug in our data calibration system when dealing with batch updates.

    Now it is solved and everything should be working fine.

    Our apologies and please let us know if something goes wrong again,

    your feedback is really appreciated.

    Guillem.
  • No, it still doesn't work.
  • And it seems website not really works as well as it should :(
  • Got mine today, but it also reads 100% humidity and 50 degrees Celsius (although it's 10 degrees outside). Hardware failure or software bug?
  • It should be fixed now, @guillem @alex did you check this ones? It seems to be a website bug

    Tomas
  • edited April 2014
    Hello all again,

    we just found a bug on the latest firmware release (v0.8.6) in Github which was causing the issue. This has nothing to do with the previous fix and it should had affected also those users who manually updated the firmware to the latest version during last week.

    We solved the bug on the platform side so you do not even need to manually update the firmware again. Anyway you can check the latest release with the bug fixed in GitHub.

    Our apologies for the inconvenience,

    Guillem.








  • Looks like it's fixed after you guys did the latest bug fix. Now, we need to get the sensors calibrated. My current temp on SCK shows 27 dec C , but it's actually 33 deg Indoors (36 deg in the sun) and humidity on SCK is 63% rh , but it's actually below 35% rh.
  • fix confirmed. since this morning, about 8 o'clock GMT I get correct readings.

    Thanks :)
  • Fixed, thanks a lot
  • After some months offline, I've connected my device again. I'm using the beta firmware 0.9 and I get a difference of 2-3 degrees in temperature.
    In this comment:
    https://forum.smartcitizen.me/discussion/comment/490#Comment_490
    You say that the algorithm has to be recalculated, talking about a previous version. Has it been recalculated?
  • Hi @xa2! Nope, it has not been recalculated yet as we still working on calibration (with the help of an environmental chamber this time) and also making improvements on the hardware and software side. The temperature algorithm is implemented on the platform so does not make any difference to use the latest firmware. Until the formula is not updated in the platform the results will continue to be inaccurate. Sorry for that! Best.
  • Any news on the issue? I'm trying to measure the temperature at our office but the readings a about 2-3 degrees too low.

    Is the error linear so that I can just pick some other thermometer to see the real difference and with that calibrate the graph to be correct?
  • Hi @artsa, no news on this issue yet. Sorry for that. I will insist on having this reviewed once and for all. On the other hand, the error should be linear. Please, let us know your results if you finally pick some other thermometer to see the difference. Looking forward to hearing from you about it. Best.
  • My device is indoors and the current temperature according to another digital thermometer next to it is 20,5. The sensor itself is measuring 17,4. Based on that difference the offset seems to be about 3 degrees.
  • I get temperature readings that are about 5°C too high and relative humidity temperatures that are about 15% too low. The SHT21 doesn't need to be calibrated and the idea that they're working with an "environmental chamber" sounds odd. Based on all of the reports that this device can't do the most basic task of getting correct temperature and humidity readings likely means that they didn't get the chips from a reliable source and most certainly didn't do any QA. I have $5 thermometers and hygrometers that give more accurate measurements than this device does.
Sign In or Register to comment.