Back to Smartcitizen.me

All set and done but no data stored


#1

Dear all,

My kit is working and submitting data.
I see the stream of my sensor (1966) in the website, which is also mentioning updates (I see data).
My mac address is registered.
I see the data on my iPhone app as well.

But…
On the map it is still mentioned “No data received” and more important: downloading data provides empty data records, so nothing seems to be stored.

What is wrong?

Regards,
Timo


#2

Moreover, through the api I get data as well…


#3

OK in some way, after about 1 1/2 day operational the website shows my data on the map. But I still get no data when trying to download.


#4

Hi @jomo_racing,

Are you still having trouble with the download? I can see your data in the test:
http://data.smartcitizen.me/test?device=1966

-Matt
SCK 685


#5

Thank you for replying.
Your URL works, but when I do https://www.smartcitizen.me/devices/export/1966.json the data [] is empty (as well as csv and xml)


#6

Hi @jomo_racing,

I can’t access your link (I’d have to be logged-in as you to do so), but you can check the API directly for the same data. Go to:

http://api.smartcitizen.me/v0.0.1/6e0428e19cf2bff1a9c05d14d0400bf4/41/posts.json

Then substitute your API key for the one above, and substitute “/41/” for “/1966/”. In the response you get some lines of info like this:

{“device”:{“id”:“41”,“title”:“SCK Hangar”,“description”:"",“location”:“Hangar, Poble Nou”,“city”:“Barcelona”,“country”:“Spain”,“exposure”:“indoor”,“elevation”:“12.0”,“geo_lat”:“41.408420000000000”,“geo_long”:“2.199940000000000”,“created”:“2013-04-25 18:34:47 UTC”,“last_insert_datetime”:“2014-03-27 13:22:16 UTC”,“posts”:[{“timestamp”:“2014-03-27 12:21:54 UTC”,“temp”:25.8,“hum”:30,“co”:290.56,“no2”:43.71,“light”:42.8,“noise”:68.4,“bat”:100,“panel”:4.44,“nets”:3,“insert_datetime”:“2014-03-27 13:22:16 UTC”}]}}

You can see in this example all the device’s data from it’s last upload.

Let us know what you find. Thanks,

-Matt
SCK 685


#7

Dear Matt,
It does work:
{“device”:{“id”:“1966”,“title”:“Timo”,“description”:"",“location”:“Utrecht, Nederland”,“city”:"",“country”:"",“exposure”:“indoor”,“elevation”:“4.0”,“geo_lat”:“52.091610000000000”,“geo_long”:“5.052920000000000”,“created”:“2015-01-10 11:20:19 UTC”,“last_insert_datetime”:“2015-01-20 07:49:17 UTC”,“posts”:[{“timestamp”:“2015-01-20 07:49:15 UTC”,“temp”:19,“hum”:42.9,“co”:227.23,“no2”:26.63,“light”:15.6,“noise”:50,“bat”:100,“panel”:0,“nets”:7,“insert_datetime”:“2015-01-20 07:49:17 UTC”}]}}

However, on the website you should be able to download datasets as csv, xml or json. Non of these options provide data. So, is this a website bug? I work in the latest chrome right now. I will check IE.


#8

In IE it does not work at all. It does not initiate a submit after selecting a format to download (CSV, XML or JSON)


#9

Yep, I’m guessing it’s a web bug as well since I’m seeing the same thing when I try to get the data from my drop-down box.


#10

Ok, thanks for confirming.


#11

You are right @rohwer! It is a platform bug. Right now we are facing issues with the mentioned “No data received”, geolocation during log-in process (you can edit it later from dashboard) and datasets download. Hopefully they will be solved very soon. Sorry for the inconveniences. Best. :slight_smile: