Back to Smartcitizen.me

Can't Register Mac Address


#1

Board: SCK v1.1
Firmware: Beta 0.8.6
Browser: Chrome 34.0.1847.131
OS: Mac OSX 10.9.2 Mavericks

Setup seems to go okay until attempting to register the Mac address. Clicking “Register The Kit” produces a JavaScript error that locks up the page (all JS powered buttons on the page become broken until the page is refreshed). Upon refreshing, the page reports that configuration of the Mac address hasn’t yet taken place.

The errors are:

GET https://cdn.api.twitter.com/1/urls/count.json?url=%2Fdevices%2Fview%2F1210&callback=jQuery181020533919660374522_1400081851376&_=1400081911560 400 (Bad Request)

GET http://www.smartcitizen.me/devices/view/null 404 (Not Found)


#2

Hi @IdeaShakerDev, I am sorry to hear you are having problems registering the MAC address. To be honest, I have registered a couple of dozens SCKs with the same browser and OS that you are using and everything went well the first attempt most of the times. I would try again the usual procedure, but checking that you are using the latest Chrome version and you also have the Codebender extension correctly installed. Please, let me know how it goes. All the best. :slight_smile:


#3

Hello,

Unfortunately, I’m still having an issue. I tried it on a different computer (OSX 10.8.4 this time) with a fresh install of chrome and codebender, and still had no luck.

I’ve made a video of the problem and the steps I’m taking, so hopefully that will help sort out if I’m doing something wrong or if it’s something else: http://youtu.be/PlBoPJbey8A


#4

Hi Paul!

Thanks for the video. Please, be sure that you have added the right Wi-Fi credentials and you SYNC before you click on REGISTER THE KIT.

I can barely see it on the video but the SmartUploader should get the Wi-Fi networks (also time/update settings) saved on the kit when the previous configuration is downloaded:

✓ Downloading previous configuration from your kit!
✓ Getting Wi-Fi networks saved on the kit…
✓ Getting time/updates settings saved on the kit…

Right after you get the message “Your Smart Citizen kit is ready!” a new form should pop up right under this messages. You should have your Wi-Fi credentials written there. If not, just write them. Then click on SYNC and you will get:

✓ Syncing with your Smart Citizen Kit…
✓ Wi-Fi settings updated on the Smart Citizen Kit!
✓ Update interval settings updated on the Smart Citizen Kit!

Then you can REGISTER THE KIT.

And do not forget to reset or switch off/on your kit in order the changes to take effect.

I hope this helps.

Best :slight_smile:


#5

Hello,

Unfortunately, I’m having no such luck. The problem persists regardless of whether or not I sync the WIFI credentials. The actual syncing seems to work perfectly (I see the messages you mentioned, and I can confirm that the credentials are saved to the device), but clicking “REGISTER THE KIT” has the same result in all scenarios.

Is it possible to register the MAC address some other way?
The device number on the web site is 1230, and the MAC address for the kit is 00:06:66:21:95:6B


#6

Hello,

I’ve finally gotten it working; it turned out to be an issue with my router after all.
I was confused because the page appears to break after registering the MAC address, but it seems that once the device begins sending data successfully, the “not configured” message goes away anyway.

Feel free to mark this issue as resolved.


#7

Great news, it is really difficult to make sure which is the problem some times, since it could be:

  • Cable
  • Firmware
  • Power
  • WiFi module
  • Platform
  • Router
  • Password encryption

and more!

but glad to see this issue is solved

Tomas