Back to Smartcitizen.me

Fail Server Time. Unable to upload data the first time


#1

Hello


I set up through the web instructions without major issue
once obtained the Mac Address: 00:06:66:36:9d:5c
I cannot get data uploaded
In serial monitor it appears :

SCK Waking ip…
SCKConnected ! !
Fail server time ! !
updates = 1
Posted to Server
Old connection active. Closing…
SCK Sleeping
Temperature … real figure
Humidity … real figure
Light Battery …real figure
Solar Panel …real figure
Carbon Monxide …real figure
Nitrogen Dioxide …real figure
Noise …real figure
Wifi Spots : 1
UTC : 2020-01-01 00:34:07 (each minute)


I have Arduino 1.6.5.
Windows 7 Version 6.1.7601Service Pack 1
SCK 1.1


can you help me where to zoom ?
thanks in advance

Josep


#2

Welcome @JosepNadalMateu! It seems like your kit is not connecting correctly to the server. Have you tried to set up your kit again!? I would tell you to upload the firmware via Arduino IDE and check if the serial monitor shows the same. Looking forward to hearing from you. All the best!


#3

Hello everybody,

I first setted up the SCK v1.1 with the browser tool (Chrome Version 48.0.2564.116 (64-bit)). It seemed to work just fine, but it didn’t uploaded any data; so I checked the Serial Monitor to verify the set up and it seemed ok when accessing through $$$ and using the basic sck commands

Then I got into this post and re-configured the SCK by uploading the modified firmware using Arduino IDE 1.6.4 for OSX El Capitan (10.11.3) (with SSIDs, Passwords, etc.) and, actually, the Serial Monitor stopped showing the:


SCK Waking ip...
SCKConnected ! !
Fail server time ! !
updates = 1
Posted to Server

…part of the message. Now it only shows:


Temperature: 27392 C RAW
Humidity: 22536 % RAW
Light: 313.70 lx
Battery: 100.00 %
Solar Panel: 0 mV
Carbon Monxide: 489.57 kOhm
Nitrogen Dioxide: 16.65 kOhm
Noise: 131 mV
<b>Wifi Spots: 2</b>
UTC: 2016-03-07 15:56:10

… which seems to be fine, although no data is being uploaded yet. So, I went again to the Arduino’s Serial Monitor and executed the $$$ and found the now I have a <4.41> in the interface and showing this output when executing get wlan auth on the Serial Monitor:


SSID=SCK_9d-7b
Chan=0
ExtAnt=0
Join=7
Auth=OPEN
Mask=0x1fff
Rate=12, 24 Mb
Linkmon=30
Passphrase=rubygirl
EAP_Id=userid
EAP_User=peap-user

Which makes me think that the firmwares uploaded by both methods must be different.

Note the rubygirl after Passphrase (not configured by me). I made a $ grep -rwin "rubygirl" . on the firmware’s folder with no results, which means that that Passphrase isn’t present as plain text in the firmware files … so what’s that being showed?

I also have the device’s MAC address registered, so that shouldn’t be the issue.

Any clues?

UPDATE:

I noted that the Serial Monitor output now shows:


*******************
Temperature: 27556 C RAW
Humidity: 20736 % RAW
Light: 253.00 lx
Battery: 100.00 %
Solar Panel: 0 mV
Carbon Monxide: 748.26 kOhm
Nitrogen Dioxide: 23.90 kOhm
Noise: 74 mV
<b>Wifi Spots: 0</b>
UTC: 2016-03-07 17:15:54
*******************

Showing no wifi spots (with the browser’s installation) showed 2 … and now, if I use set wlan ssid ... to set ssid, password and auth method, I still get the 0 under Wifi Spots.


#4

I recommend you that you configure your SCK with arduino app. Open sck beta 0_9_0 project and change Constans.h file. Then upload sketch to SCK. I’ve also post (2 or days back in another discussion) how to fix UTC time problem.


#5

I did it that way on my second attemp, modifying the Constans.h …


#6

Hello @fernando,

We are working hard on fixing this issues. Some times they are difficult to replicate and this makes them twice difficult to fix.

Thanks @romanv to point him to the “Compilation way”…

For others fighting the same issue we temporary recommend following the:

Manual set up: The Compilation Way section on the documentation.

http://docs.smartcitizen.me/#/start/manual-set-up-the-compilation-way

I will come back to you when the issue gets fixed.

Guillem


#7

Thanks @guillem,

Please let me know if there’s something I can help with on my end, I’ll be waiting for any news.

Regards


#8

Hi @fernando,

Do you mean even by following Manual set up: The Compilation Way section on the documentation.

http://docs.smartcitizen.me/#/start/manual-set-up-the-compilation-way

You are still unable to set the kit online?

Thanks!


#9

Yes @guillem,

First I setted the SCK through the Chrome Extension and then, after seeing the problem, I did it by setting the firmware vairables as shown on the Compilation Way … with no results …

This is the output if I check the serial monitor:


SCK Waking up...
SCK Connected!!
updates = 1
Posted to Server!
Old connection active. Closing...
SCK Sleeping
*******************
Temperature: 26148 C RAW
Humidity: 28168 % RAW
Light: 183.00 lx
Battery: 100.00 %
Solar Panel: 0 mV
Carbon Monxide: 488.47 kOhm
Nitrogen Dioxide: 0.86 kOhm
Noise: 238 mV
Wifi Spots: 2
UTC: 2016-3-28 19:19:33
*******************
SCK Waking up...
SCK Connected!!
updates = 1
Posted to Server!
Old connection active. Closing...
SCK Sleeping
*******************
Temperature: 26264 C RAW
Humidity: 27692 % RAW
Light: 183.80 lx
Battery: 100.00 %
Solar Panel: 0 mV
Carbon Monxide: 534.05 kOhm
Nitrogen Dioxide: 1.25 kOhm
Noise: 6 mV
Wifi Spots: 2
UTC: 2016-3-28 19:20:33
*******************

And if I go into the command mode ($$$ on the serial monitor) it shows:


wifly-GSX Ver: 4.41 Build: r1057, Jan 17 2014 10:26:26 on RN-131
MAC Addr=00:06:66:36:9d:7b
*READY*
Auto-Assoc Fablab chan=1 mode=MIXED SCAN OK
Joining Fablab now..
Associated!
DHCP: Start
DHCP in 2679ms, lease=3600s
IF=UP
DHCP=ON
IP=192.168.0.41:2000
NM=255.255.255.0
GW=192.168.0.1
Listen on 2000

And when checking the SSID and Phrase, they are correct …

Just to verify, I also made a $ping 192.168.0.41 (the IP it seems to have) and actually it appears connected (during intervals, which must be normal).


equest timeout for icmp_seq 183
ping: sendto: Host is down
Request timeout for icmp_seq 184
Request timeout for icmp_seq 185
64 bytes from 192.168.0.41: icmp_seq=186 ttl=255 time=23.441 ms
64 bytes from 192.168.0.41: icmp_seq=187 ttl=255 time=4.936 ms
64 bytes from 192.168.0.41: icmp_seq=188 ttl=255 time=4.892 ms
Request timeout for icmp_seq 189
Request timeout for icmp_seq 190
Request timeout for icmp_seq 191
64 bytes from 192.168.0.41: icmp_seq=192 ttl=255 time=2.564 ms
64 bytes from 192.168.0.41: icmp_seq=193 ttl=255 time=6.714 ms
64 bytes from 192.168.0.41: icmp_seq=194 ttl=255 time=4.863 ms
64 bytes from 192.168.0.41: icmp_seq=195 ttl=255 time=4.956 ms
64 bytes from 192.168.0.41: icmp_seq=196 ttl=255 time=4.609 ms
Request timeout for icmp_seq 197
Request timeout for icmp_seq 198
Request timeout for icmp_seq 199
Request timeout for icmp_seq 200
Request timeout for icmp_seq 201
Request timeout for icmp_seq 202
Request timeout for icmp_seq 203
Request timeout for icmp_seq 204
Request timeout for icmp_seq 205
Request timeout for icmp_seq 206

So it doesn’t seem to be a problem at this end …

Thanks for any help


#10

UPDATE, after a looooong while, it is uploading data …


#11

Thanks for the feedback @fernando

Please report any other issue to support@smartcitizen.me so we can quickly work on it!