Back to Smartcitizen.me

Fail updating RTC


#1

Hi,
My smart citizen kit never worked and after some investigation I think I understood why:
It looks like it is not able to make the RTC working.
I get the “Fail updating RTC” message when the device start and then all the update
to server goes with an invalid date.
My kit does not have a clock battery installed: cloud that be the reason why is not working ?

Best
Marco


#2

Hi @piff (Marco),

I don’t think so. My SCK worked just fine for before I decided to install a battery. The button cell battery isn’t required/ supplied with the SCK, but f you want one, it is a CR1220 (as long as your primary battery is attached, and it’s charged, the button cell battery isn’t needed.)

I think The RTC gets updated when the SCK connects to the SC server:

    if (base_.checkRTC())
    {
      if (server_.time(time))
      {
        while (!base_.RTCadjust(time)&&(retry<5)) retry++;
        #if debugEnabled
                if (!debugON) Serial.println(F("Updating RTC..."));
        #endif
      }
      #if debugEnabled
        else if (!debugON) Serial.println(F("Fail updating RTC!!"));
      #endif

(The code above was copied from lines 171-183 here: https://github.com/fablabbcn/Smart-Citizen-Kit/blob/master/sck_beta_v0_9/SCKAmbient.cpp)

@aitoraloa, can you confirm that the time is updated when the SCK connects to the SC servers? Thanks,

-Matt
SCK 685


#3

Hi @piff and @rohwer, Yes! I can confirm that the Smart Citizen Kit requests a RTC update every time it connects to the Smart Citizen server for the first time (also when you turn the kit off/on), even before the sensors start to gather data.

@piff: Sorry to hear that you are having issues with your device. First of all, I would recommend you to try the SCK_check utility form our GitHub repository:

In order to use these utilities, you will need to use Arduino IDE to upload the sketch and the serial monitor to see the message. Please, copy and paste the message that you get and sent it to us. Best.