Back to

Help needed with 'not connected' error

I bought an SCK 2.1 with a view to installing several externally in my local area, which is an air pollution hotspot. However, I am not having much luck with getting the first sensor working.

When I first received and set-up the SCK worked perfectly, but it was it was in my kitchen, and I wanted to install it outside. Frustratingly, the SCK didn’t come with a protective case, so I turned it off while I arranged to source one. The next day I decided to set up the SCK in different internal room while I waited to get for the case.

However, when I turned the SCK on again there was no data being reported to the website. All data readings showed as ‘N/A’ and the battery symbol showed ‘Not Connected’. However, the ‘last data received’ was continually updating. The SCK was connecting to the website, but not transmitting data.


I tried resetting the SCK and reconnecting it to the Wi-Fi network. I updated the Firmware and it still didn’t work. I saw that some other people had the same problem on the forum, so I connected to the SCK to my computer and accessed the shell. All the sensors are disabled and only the battery is enabled. I can turn on the sensors individually and they report to the website, but as soon as I disconnect the SCK from my computer the sensors are disabled again.

  • Is there a way to enable all sensors in one command?
  • Can anyone suggest how to stop the sensors turning off when the SCK is unplugged?

Thank you very much for your help in advance.


Version information:
Hardware Version: 2.0
SAM Hardware ID: 32F62D5750573651302E3120FF192B17
SAM version: 0.9.6-3e7b809
SAM build date: 2019-09-09T15:55:30Z
ESP MAC address: EA:DB:84:85:29:46
ESP version: 0.9.2-a91f850
ESP build date: 2019-08-20T13:17:16Z

HI James,

The build date for the Firmwares looks somewhat old to me - 2019 - wow its pre-CV19; a lot has happened since that time !. May I suggest you look at update to the latest firmware for both and then try it again. The documentation on how to do it is found at
By the way - Where (from which shop) and when (approx) did you purchase your kit ?


Thanks for taking the time to reply to me. I followed the update fimware instructions as suggested and I have identified what I did wrong.

The index.htm file referred to in the instructions takes you directly to the 0.9.6 firmware for SCK 2.0. I obvioulsy didn’t read the text clearly enough, and so on my first attempt at updating the firmware after buying the SCK, I inadvertently updated SCK 2.1 with the 0.9.6 firmware for 2.0! No wonder I had issues.

Updating to 0.9.7 for SCK 2.1 didn’t remedy the issue despite a couple of factory resets. But upgrading to the 0.9.8 pre-release and a further factory reset instantly kicked all the sensors back on after a reboot.

Clearly the firmware update process needs to be made more fool proof for fools like me!

Thanks again


Noted. I am certain @oscgonfer will take it on board but right at the moment I am aware he has a fair bit on his plate (my reason for responding instead of him), so it might take a little while.

Cheers and all the best with your kit

1 Like