Back to Smartcitizen.me

How can I solve my problems?


#1

Hi,

After having installed my SCK next week, I got a problem with pression and humidity always getting 50°C and 100% humidity.
As requested, I updated my SCK with the last release.

Now i got this in my arduino

Temperature: 27452 C RAW
Humidity: 21892 % RAW
Light: 210.0 lx
Battery: 70.0 %
Solar Panel: 0 V
Carbon Monxide: 363.649 kOhm
Nitrogen Dioxide: 8.506 kOhm
Noise: 47 mV
Wifi Spots: 0
UTC: 2000-01-01 00:18:51

FIRST PROBLEM :

In my first setup, I found between 9 and 12 wifi spotted, now, nothin.

SECOND PROBLEM :

When adding my sensor to the network, I don’t have any problem.
But when I try to configure it, when I click on "start process’, i got the following logs :
✓ Checking your Smart Citizen Kit version. This could take a while, please wait.
✓ Your kit is running an older firmware. This is not the latest firmware.
✓ Press Upload Firmware to upgrage the firmware of your Smart Citizen Kit

Then I select my version (1.1) and click on “upload firmware” and I got the following result after 3 attemps :

✓ Firmware update failed! Could not upload sketch to your Smart Citizen Board. Try unplugging your Smart Citizen Kit and connecting it again. Retrying 2 of 2.
✓ Trying Smart Citizen Kit auto-reset. If it does not reset automatically please reset the Smart Citizen Kit manually!
✓ Firmware update failed after 3 attempts. Please, reset your kit or try to upload the firmware manually. More info

The first time I registered and configured my sck, I don’t had any problems and I configured the wifi successfully.

So, How can I solve those problemes ?
Can someone help me please ?

PS : I checked my SCK with the check script and all was ok.


#2

What is your operating system and browser you are using? Have you tried to put the firmware manually and the network manually?


#3

As i said, all worked the first time, now, I’m totaly unable to redo it.

About the firmware, I have downloaded the last on github and load it on the sck with the arduino software (is there another method ? )

My browser is firefox.


#4

To add networks manually make the changes as shown in the images, replacing it with your network settings and upload the firmware.


#5

Ok, thank you.
Now, it sends data successfully to the website.

BUT

I still have the problem with temperature and humidity (50°C and 100%)
So first problem resolved, thank you.
Now, I only need to solve this data problem …

Is that a problem on the website ?


#6

Yes, seems to be a problem with the website. Looked like it had been fixed, but apparently not, in the next few hours to look at him to fix.


#7

OK thank you

I’ll follow this bug fix.

Do you know why as had to do it manually ?


#8

Tried to reboot the browser? Sometimes I found that the USB port is not working, although it detects the USB is connected, if you restart the browser works again.


#9

It has failed several day, so I don’t think it’s a browser issue