Back to Smartcitizen.me

How to setup the SCK on Ubuntu?


#1
  1. I am trying to setup the SCK on Ubuntu. From the browser the Java plugin loads the configuration form but I cannot tell if the settings are stored to the board. It still tells me:

It seems this kit haven’t been configured yet (no macaddress registered). Please go to the configure page and be sure to register the mac address of your kit.

  1. Further, I tried connecting via Arduino 1.0.5. I set the board to “LiliPad Arduino USB” and set the port to “/dev/ttyACM0”. I opened the latest SCK Beta 0.8.5 and uploaded it to the board. The Arduino IDE responds with “Done”.

I entered the wireless configuration data into the “SCKBase.ino” file and uploaded again. The Arduino IDE responds with “Done”.

  1. I try to open the “Serial Monitor” in the Arduino IDE to retrieve the MAC address. The following error appears at the shell I started the IDE from:

RXTX fhs_lock() Error: creating lock file: /var/lock/LCK…ttyACM0: File exists

I still cannot tell if anything has been uploaded to the board.


#2

Hi there

we have a subdomain called http://sandbox.smartcitizen.me in order to try the new adds to the platform

I am asking to proceed with the same steps as you are doing, going to configure, but make sure you are inside the subdomain in order to get the new registration process

this should be the link (once logged in): http://sandbox.smartcitizen.me/devices/configure/(yourdevicenumber)

use Chrome as a browser, it might ask you to install the code bender plugin, this is a complex process we are simplifying, once you do those steps it should be fine

let us know how it goes

Tomas


#3

Hello there

Can you please try to use this registration/firmware update process from our sandbox? http://sandbox.smartcitizen.me

it is still beta, but solves most of the know issues with platforms and browsers

please let us know how it goes, this is not an official release yet

thanks!

Tomas


#4

Hello Tomas.
I am not sure if I exactly understand what you mean. Can you please point me to the exact page/link which you want to me to try?
I suspect you mean the “Configure” menu item which is listed at the page of my sensor (see screenshot).

I walked through the “Configure” steps before but as I wrote I am not sure the configuration is stored on the device. One indicator is that the MAC address seems to be still missing as the warning message tells (see in my initial post).


#5

First I tried Chromium on Ubuntu. There is a JavaScript error (missing function) which stops CodeBender from working. Firefox on Ubuntu almost freezes.
Then I tried Chrome on Windows 7. It stops at the Updating Firmware screen. You can wait for hours. Finally I looked into the JavaScript Console of the browser to find the following error message:

Failed to load resource: the server responded with a status of 404 (Not Found) http://sandbox.smartcitizen.me/firmwares/json/sck_beta_k.1.1_v.0.8.6.json

#6

@guillem, can you please check this issue? lets talk with the code bender guys to check what might be the problem, or if it is ours


#7

The device was delivered weeks ago. I still cannot use it. I find it quite frustrating. Please let me know if you have a solution to the problem. Why is it so difficult to fix the download link?


#8

Please,

use our production platform which also supports the new configuration tool since more than two weeks ago.

smartcitizen.me

Please, let me know if something goes wrong.

Guillem.


#9

I cannot use the Codebender plugin on Ubuntu with Firefox or Chromium. I cannot use it with Firefox on Windows - it freezes the browser. The plugin works with Chrome on Windows. But uploading the firmware fails.

This is written to the browser console.
Object {status: “OK”, response: null, debug: “no response but not necessary to validate”}

Can you please test these browsers and fix the plugin/firmware upload?!


#10

Finally, I was able to upload the firmware - thanks to Stackoverflow.

Believe it or not - the trick was to use another USB cable. It was a shorter one but I cannot tell if this important. Here is a related post: Error: buffered memory access not supported


#11

Thanks for the tip and the link! I am really happy you could finally upload the software. Best. :slight_smile: