Back to Smartcitizen.me

I'm seeing only UDP broadcast packets using wireshark... what can I do?


#1

My sck is not transmiting to server. I’m seeing only UDP broadcast packets in my network… so what should I try?


#2

I have seen this with a serial conection:

Error posting on Server…!
Duerme


Temperatura: 33.00 C
Humedad: 26.20 %
CO: 174101 Ohm
NO2: 9544 Ohm
Luz: 11.60 %
Ruido: 50.00 dB
Bateria: 60.70 %
Panel solar: 0 mV
Redes: 20
UTC: 2013-07-19 19:13:17


wifly-GSX Ver 4.00.1, Apr 19 2013 11:48:28 on RN-131
MAC Addr=00:06:66:21:17:29
READY
Auto-Assoc Mywifi chan=11 mode=MIXED SCAN OK
Joining Mywifi now…
Associated!
DHCP: Start
DHCP in 1954ms, lease=86400s
IF=UP
DHCP=ON
IP=192.168.1.34:2000
NM=255.255.255.0
GW=192.168.1.1
Listen on 2000

I’m trying to figure out how to debug this, but can’t find nothing like an easy howto debug it!!!

Some help would be awesome!!!


#3

Everything looks good, what kind of network do you have?


#4

I have deleted my sensor from database and started again… i will try to plan my tests to find out what’s going on.


#5

Well, I started charging the last firmware “Sck_test_beta_v0_6b”. It has gone well.

Then I configured my new sensor, and all seems to have gone well too.

This is what I saw from my serial:


<4.00> factory RESETrebootexit
CMD
4.00>

<4.00> set wlan ssid Mywifi
<4.00> set wlan auth 4
<4.00> set wlan phrase Mypassword
<4.00> set ip proto 10
<4.00> set sys autoconn 0
<4.00> set wlan join 1
<4.00> set comm remote 0
<4.00> set ftp address 198.175.253.161
<4.00> set wlan ext_antenna 0
<4.00> set ip dhcp 1
<4.00> save
<4.00> reboot
Auto-Assoc Mywifi chan=11 mode=MIXED SCAN OK
Joining Mywifi now…
Associated!
DHCP: Start
Despierta
Conectado!!
updates = 312


But now I’m in the same trouble. I’m not seeing any upload to the server in my network sniffer, only UDP packets to a broadcast IP. This is the payload:


f!)E(p"vK09o6Time NOT SETwifly-GSX Ver 4.00.1, Apr 19WiFly-GSX8:31M


I think something is going wrong because of the message:

Time NOT SETwifly-GSX Ver 4.00.1, Apr 19WiFly-GSX8:31M

What can I try???

Regards!!!


#6

Well, I have done another test. I have accessed to the command console on serial port, and done this:


<4.00> get time
TimeEna=0
TIMEADR=64.90.182.55:123
Zone=7
<4.00> show tt
Time NOT SET
UpTime=36 s
<4.00> time
AOK
<4.00> show tt
Time=18:13:13
UpTime=64 s
<4.00>


Now the UDP packets says this:


f!)Ez"v09o6 RUTime=18:15:46wifly-GSX Ver 4.00.1, Apr 19WiFly-GSX8:31


But still there is no data upload to server!!!

I’dont know how to continue!!!

Regards.


#7

I have rebooted the sck, and now I’m seeing again wifly time is not set…

What can I try??? can i send you my board for your testing???


#8

The time server is taken from the web page smartcitizen, time of wifly not matter, it seems that I have an overflow of updates. I can tell you see when you start the module?


#9

This is what i get when i reboot the sck by the serial port:


<4.00> reboot
Rebootwifly-GSX Ver 4.00.1, Apr 19 2013 11:48:28 on RN-131
MAC Addr=00:06:66:21:17:29
READY
Auto-Assoc Mywifi chan=11 mode=MIXED SCAN OK
Joining Mywifi now…
Associated!
DHCP: Start
DHCP in 1712ms, lease=86400s
IF=UP
DHCP=ON
IP=192.168.1.34:2000
NM=255.255.255.0
GW=192.168.1.1
Listen on 2000



#10

It’s all right, look at my network.

READY
.Auto-Assoc Mi Red chan=7 mode=MIXED SCAN OK
.Joining Mi Red now…
.Associated!
.DHCP: Start
.DHCP in 1681ms, lease=86400s
.IF=UP
.DHCP=ON
.IP=192.168.0.3:2000
.NM=255.255.255.0
.GW=192.168.0.1
.Listen on 2000

You can try another network?


#11

I know my sck is conected to my network (i have seen it in my router, in my network sniffing, etc…), but why it’s not sending data to server? How can i debug the code to know where my sck is stopping or pausing? Can you confirm that there is no data from my sensor in the database? Any other problem with the access to the server? which is the normal output from the serial port?

My first sensor was 155… now i’m 343

Regards!!!


#12

If you get an error when posting, is not uploaded to the server. In any case send an email to support@smartcitizen.me