Back to Smartcitizen.me

Is the apikey needed to upload data?


#1

My device is not transmitting any data to smartcitizen.me. I am running the following firmware:

wifly-GSX Ver: 4.41 Build: r1057, Jan 17 2014 10:26:26 on RN-131

I wonder if the apikey is needed to upload data to the website? There is no configuration option in Constant.h of the recent sck_beta_v0_9 firmware from the SCK Beta 0.9.2 release.

Further, I tried to set the apikey as stated in the documentation via the Serial Monitor of the Arduino software. Here is the result:

<4.41> set apikey MYSECRETAPIKEY
ERR: 2few Args

When I retrieve the apikey this response is shown:

<4.41> get apikey
SSID=SCK_af-18
Pass=
Linkmon=3600
Beacon=102
Reboot=0

Can you please explain what SSID means here? When I retrieve the WLAN configuration the SSID of my router is set correctly.


#2

Hello,

API KEY is not currently need it.

You just need two steps:

  1. Set your wi-fi credentials using any of the available methods in order your SCK can reach the internet.

http://docs.smartcitizen.me/#/start/getting-started

  1. Register your kit mac address on the platform as described on the previous steps.

In order to quickly check your kit is publishing you can enable the debug mode as described here.

http://docs.smartcitizen.me/#/start/is-my-kit-pusblishing-data-properly

Let us know how it works!

Guillem


#3

Thank you. I tried the debug mode but still no data is submitted.

I can see on my router that the device is connected. On the Serial Monitor the IP configuration is printed when wake up the device with $$$. When I exit the command mode the device outputs the sensor values as expected.


#4

Can you please help me to get data transmitted to the website? I cannot get it running for months.


#5

@tbsprs Sorry for the late reply.

Please, contact support@smartcitizen.me We will try to debug it remotely or replace the hardware.


#6

Same problem here. When I debug the website, it tells me: kitData is undefined. Is my board broken?


#7

Tried with the second board I bought (I bought 3 in total, same issue. Website throws javascript error kitData is undefined). I have good hope it is no problem with any of the boards but just with the website being messed up.