Back to

Light sensor issue

There seem to be problem with the light sensor of my new smart citizen start kit. When I try to issue the command “monitor light”, there is an error: “Light is disabled, enable it first!!!”. When I tried to enable the light sensor, I encounter error message: “Failed enabling Light”.

I also notice that when I first power on the unit, the console shell show that “No urban board detected!!” and all the sensors are disabled. I can manually enable the sensors through the shell except the light sensor.

Please advise if there is a way I can fix this or it is a hardware issue?

My hardware is:

Hardware Version: 2.1
SAM version: 0.9.5-a91f850
SAM build date: 2019-08-20T13:25:01Z
ESP version: 0.9.2-a91f850
ESP build date: 2019-08-20T13:17:16Z

I had tried to reset the board to factory default and upload with latest firmware but both way it still has the same issue with light sensor.


I’m experiencing exactly the same issue. Another question is…how can I make the new enabling sensor configuration to stick in the time? When I remove the USB wire from the kit it comes back to the former configuration where only the battery sensor is enabled.

Please help on that. My hardware is:
Hardware Version: 2.1
SAM Hardware ID: 2112BB525054414B352E3120FF17162B
SAM version: 0.9.5-a91f850
SAM build date: 2019-08-20T13:25:01Z
ESP MAC address: 4A:3F:DA:09:98:57
ESP version: 0.9.2-a91f850
ESP build date: 2019-08-20T13:17:16Z

I am not from Fablab, but as an electronics tech I suggest the following back to basics steps to isolate the problem.
@chan.chung.kit @dcasado

  1. Disconnect all power, including the battery if you have one. Also disconnect the dust sensor.

  2. Remove the urban board and examine the rows of pins underneath. Are any of them bent (even slight bend can cause poor contact with the main board). Look from all angles in good light. If any are bent then very carefully, using needle nosed pliers, straighten the pins by bending them very slowly. All of the pins should be parallel and lined up exactly.
    If any pins break during this procedure then you will need a new board so do it gently !!!
    Also examine the board overall to see if anything else grabs your attention such as debris, dislodged components etc.
    All ok ?

  3. Replace the urban board taking great care to line up the pins into the sockets on the main board. Line up the pins on the urban board so that each pin rests in the middle of the corresponding hole on the data board socket before pushing the two boards together with firm pressure until the base of the urban board pins meets the plastic on the socket with no discernible gap along the whole length. Sometimes it is necessary to apply a very slight longitudinal rocking motion to get the pins and socket to go in. Also check for any unexpected resistance as you apply pressure to the boards and that no pins have popped out.

  4. Repower the board, plug in the usb cable and see what the serial monitor in Arduino IDE tells you when the SCK powers up. Are there any errors ? Use the sensors command to see what sensors are recognized now.

  5. At this point you should see all of the sensors that are on the urban board and the main board (main board has only the power sensor) are enabled. You should also see the dust sensor enabled if it’s plugged in.
    If not detected you can try enabling the sensors 1 by one. See if it responds in the manner expected.
    If this has all failed, then the Final possibility is to perform a master reset (see documentation for procedure)

At this point, without your having test equipment or technical skills, if it’s still faulty, then maybe it’s time for a discussion with Seeed technical support about getting a replacement urban board or the whole kit. It’s a possibility your board is damaged.
If it’s available, you could buy the bare bones kit for a little less than the full kit.

I hope this helps.

1 Like