Back to Smartcitizen.me

Lost in configuration


#1

Hi,

I failed to configure my sck 1.1. I tried multiple times using the web interface. I’m getting no error message once it’s done and everything seems to work fine. HOWEVER, the web interface keeps telling me two things in my sensor’s details : 1) no data recieved yet and 2) your device doen’t appear configured 'cause there’s no mac address associated with it.

After trying using the web interface 10+ times and tried manually with arduino IDE. Here again, no error feedback. I see that the device is recording data because I saw data showing on the output every 1 minutes. This indicates that the device seems configured ok because I actually set the updates to 1 minute and the publishing to 1 minute.

About the mac address, I entered the last 12 digits on the wifi module at first (which is what the tutorial told me). After that, I tried to obtain it using the serial monitor, but it returned only 6 digits “17:57:52”. I tried to complete with the first 6 digits on the board for “00:06:66:17:57:52”. I don’t know if this is worng or good, but my mac address is still not saved on the web interface and I’m gettin the same error message stated earlier.

I am lost, please help.

Thanks,


#2

Hello @Guliavan

Can you tell us which OS and browser are you using? there have been some issues with Windows 8 and Explorer, a good configuration is Chrome + Mac

We need to check if your WiFly module is corrupted which is seems not, it seems a communication through the serial port issue

Sorry for the late response

Tomas


#3

Hi,

I’m using firefox on mac (mavericks). I’ll try with chrome and post an update here. However I’m not optimist since I performed the config manually and wasn’t able to get any farther.

David


#4

I tried with chrome on mac and it didn’t work either. I made sure to put the right info and encryption type for the wifi. It tells me that the sync went ok, but still not data sent from my device. I’m also still not able to configure the mac address on the site: when I register the mac address with the numbers on the board, I come back to configure and the field is empty.

At some point the site told me, when I tried to configure, that the firmware on the board wasn’t up to date. So I clicked on the “update” button, but the site was stuck on “updating firmware…” for a few hours so I decided to refresh the page and start over. But the next time, I had no message about the firmware update and did the sync as I always did. The site still tells me “No data received yet”

I don’t know what to do now…

David


#5

Hi David

Maybe you can try the manual update in the tutorials section on the site? it might be an option to discard hardware problems. Otherwise we can Skype next week and try to debug your problems remotely

Tomas


#6

Hi,

I tried this also. I’m able to configure the kit. I got the sensor information via the terminal, but it appears it won’t connect to my wifi network even tough I configured it with right protocol, ssid and passphrase…

:frowning:


#7

Note that I’'ll be on a trip until june 15th so I won’t be able to debug it very soon


#8

I reconnected to the kit using serial. Note that I sill have a problem with the mac address.
When I type “get mac” in terminal, the kit returns : “17:57:52” and not 6 pairs of digits as the tutorial says :
"- In the MAC address text input, paste the MAC address given by the command get mac. It should be something like: 00:06:66:21:17:33"

Can this be a problem ?

Note that I tried to register the kit using 00:06:66:17:57:52, replacing the first 6 digits with 00:06:66. It didn’t work. I also tried to register using the last 12 digits on the wifi card as stated on the cofiguration page. The digits are not the same “00:06:66:21:7D:DA”. But it didn’t work either.


#9

This is the data I see from the device:

Temperature: 26956 C RAW
Humidity: 25664 % RAW
Light: 307.9 lx
Battery: 100.0 %
Solar Panel: 1.485 V
Carbon Monxide: 753.686 kOhm
Nitrogen Dioxide: 8.205 kOhm
Noise: 0 mV
Wifi Spots: 0
UTC: 2000-01-01 00:12:23

I see that the wifi spots is at 0 even though I set my wifi config correctly


#10

Try the sck_check firmware, and also verify that the wifi module works correctly.


#11

I am facing the same problem. The leds blink, indicating that some activity is being performed, and also the sensor readings are displayed on the serial monitor.

I have no errors when configuring using the web page or the Arduino IDE kit but the web page still remains indicating that the kit was not registered and that no data was sent.

Is there any way to enable debug messages through the serial port? Commands how to ‘get mac’ and ‘get wlan ssid’ return nothing and not always the $$$ works (eventually I get the message ‘Please, wait the wifly sleep’).

Please, could someone help me?


#12

When you encounter problems with the wifi module, try the sck_check utility. This utility will indicate through the arduino serial monitor, if the module works correctly. If not tested in this way, the only thing to do is guesswork and will not reach any solution.

I put a tutorial and arduino serial terminal.


#13

Hello @mdeheras,

Thanks for the information.
I ran the sck_check which indicated that my wifi was not corrupted just needing an update.

I managed to turn on the SCK´s debug and now I can see the messages during startup. The firmware update starts but does not finish and I get the message “Update Fail”.

Even without completing the update, yesterday I managed to register and connect the sck and transmit data over a certain period. Today I went back to have connection problems again.

There is another way to update the firmware of Wifly?
What is the password to access sandbox.smartcitizen.me?

Regards

Rostand


#14

Hi @rostand, I have been setting up several kits for the last weeks and it is true that sometimes when updating the wifly firmware you can I get the message “Update Fail”. This does not mean that the update is not done. To see if it is done or not you need to reset (or turn off/ turn on) your kit and open the serial monitor again. As soon as you do this you have to write “get wifi info” above and if you get “441” that means that the update is correctly performed. I know that this might sound silly but most of the connection problems (I have suffered them too) can be solved by turning off/on (or resetting) the SCK. Please, let me know how it goes. Best.


#15

Hi @aitoraloa

I updated my kit to beta version 0.9 and the problem is gone.
My device is working fine now.

Thanks,

Rostand


#16

Hi @rostand, Thanks to you for letting us know. I am glad to read that the problem is gone and your kit is working fine. I will take note for the future. All the best. :slight_smile:


#17

Hi,

Sorry for the very late update. I went on vacation and the summer was pretty busy.

Anyway I ran the SCK_Check as you suggested. It told me this :

Trying to connect.
Firmware version: 0
Error reading version.
Wifi device is corrupted :frowning:
Want to test the EEPROM? (y/n)

And then I entered ‘y’ and the program did go one for a while with many “…” lines and I got bored at line 300 :wink:

So what do we do with that corrupted wifi module ? Is it worth trying to update it ?

Thanks for your help,

David


#18

Hi @Guliavan, Sorry to hear that you got the “your wifi device is corrupted” message running the SCK_Check. The only way to recover the WiFly module is using an RN-ISP programmer, that we have been waiting to receive at least for three months now. Could you, please, send an email to support@smartcitizen.me with all your details and a brief explanation of your problem!? You can just copy-paste the text above so we can add you to the “corrupted wifly” and replace your SCK’s base board ASAP. Once again, sorry for the inconveniences and thanks for your support. Best.


#19

That’s ok. Thanks for your help, I’ll reach out to support !