Back to Smartcitizen.me

New firmware


#1

Hello all,

we released the new firmware for the kits: https://github.com/fablabbcn/Smart-Citizen-Kit/releases/tag/v0.8.5

it works with all versions. An important thing to take care when upgrading in the Arduino IDE

  • for V1.0 (Goteo): use Arduino Leonardo
  • for V1.1(Kickstarter): use Arduino LilyPad USB

To register the kit use Firefox and check your java security settings

This is a not yet official launching of the Firmware, we will do a major communication in few days about the new registration process and more news!

Thanks and sorry for being so silent some times!


#2

Binary sketch size: 27,898 bytes (of a 28,672 byte maximum)
Found programmer: Id = “BqŸ”; type = 0
Software Version = 0.0
avrdude: error: buffered memory access not supported. Maybe it isn’t
a butterfly/AVR109 but a AVR910 device?

when I try to Upload

The website won’t let me click to set my location. It’s not browser friendly at all…


#3

Hi mike,

About uploading the new firmware :
It seems you are using arduino 1.5.5. If this is the case, try to avoid the use of beta software and try the official stable release, the 1.0.5.

About the sensor location, could you please describe more in detail the problem, especially which browser and OS you are using.
Also for clarity, could you open a separate post about it on the forum, with the category “inerface” / “Web Bugs”.

Thanks

Till soon.
A


#4

Hello all,

last friday we just officially released in GitHub the latest version of the firmware: 0.8.6.

This version was already being uploaded by the new Platform configuration tool since last month.

You will find always the latest version of the firmware here:

https://github.com/fablabbcn/Smart-Citizen-Kit/releases/

For advance users you can always check the development branch with our latest work.

Stay tuned! We will be releasing version 0.9 soon.

Guillem.


#5

We just found an small bug on the last 0.8.6 Github release.

Please, in case you download it previously last week, we encourage you to download it again.

We remember you this is just a feature for advanced users, the platform configuration tool will always update your kit to the latest firmware version automatically.

Thanks,

Guillem.


#6

I uploaded 0.8.6 yesterday with Firefox on OSX. After installing the firefox plugin and restarting firefox it worked very well. A very big improvement to last time. Thanks.

Actually the Sensor is near the street, but out of the WLAN range, aquiring data.


#7

If you want to increase the range of wifi, I recommend you put an external antenna, for example this:

http://es.mouser.com/ProductDetail/Microchip-Technology/TRF1001/?qs=sGAEpiMZZMuBTKBKvsBmlHh7qrTiLmJgqiaQgYrMYKI%3D


#8

Thanks for the link. When I rotated the kit i had a connection. Nevertheless for the future I will get and use an antenna.
Re hardware actually I have exchanged the battery and use two 18650 ones (connected in parallel). They won’t last long (i hoped min one week) so i will put a litte solar panel.
Right now software is more important.


#9

-solved-


#10

Hi Tomas,

I was trying to update the firmware using the Code bender plugin on Safari and Chrome but it crashes constantly. I also tried to perform the update using Arduino IDE, but it doesn’t work. Any advice?

Best


#11

Same here. And it seems like during the update the port gone missing and you can’t use or see it again without reset/power off. (Mac OS X 10.10 & 10.9 / Arduino 1.0.6/Chrome/Firefox)


#12

@Ravensbourne Not sure if it is helpful but I was fighting with the setup a while ago. I do not know if it still works now.