Back to Smartcitizen.me

No data yet

I am writing in about device 507. I have configured my device and registered it several times. Every time it tells me that everything is fine and ready to go. Yet my device still has not been able to upload data. I haven’t been able to find any clearly helpful documentation on the site. I’ve installed firmware using the Arduino IDE. I don’t know what to do anymore. Please help.

Hi @terraphorm. Sorry to hear that you are having problems gathering data from your device. Could you tell us what you see in Arduino IDE’s Serial Monitor after uploading the firmware!? Best.

Hi @terraphom,

It looks like data is feeding now.

-Matt

Hi. It seems my sck 2048 is correctly connected but when clicking over the dot on the map, is appears “no data received yet”… But as I click over “explore” button it appears down the page the correct readings (I suppose…) but no graphs. What to do?

Correcting my previous post: I can see de graphs on the web, but still “no data received yet” message.

And suddenly my SCK goes offline. Apparently for no reason: it is connected to the power via usb charger, wifi is going well and leds are blinking as before when on line (but I don’t know if they blinks correctly, I haven’t found any information over the meaning of the blinking leds…)

Upgrading last post. I’ve reconfigured via web my SCK and actually it seems it goes well. But still no data on the web.

hi @rsalgas, We still facing issues with the mentioned “No data received”. As far as I know seems a pretty hard-to-find cache bug. The backend members of the SC team are still working on it. Hopefully, it will be solved soon. Fingers crossed! Sorry for the inconveniences. Best. PS: “meaning of the blinking leds” doc coming soon.

Hi aitor. Everything went ok until yesterday morning, data on the web too. I’ve had a shut down of power supply at home and although it was fixed, actually I’ve no data on the web but I’ve data via API.

Hi @rsalgas,

Same thing happened to my SCK when I took it apart to work on the enclosure. It took a few days to show up on the web again, but data was still being posted. I checked your feed and yes, your updates are still coming in. You can expect to see them on the website soon.

As for the LEDs, here’s the explanation I wrote last week for the new FAQ that will be coming out soon:

There are 5 LEDs, they are all on the base half of the SCK. They can be understood in three groups:

  • LED2 and LED1 - These are the two yellow (or orange) LEDs in the lower center-letf of the board. You will only see these lit when your USB cable is connected to the SCK and you are configuring or otherwise interacting with the SCK. LED2 is the “RX USB” and will be lit when the SCK is receiving information via the USB connection. LED1 is the “TX USB” and will be lit when the SCK is sending information via the USB connection.
  • LED4 and LED3 - These are the two blue LEDs in the lower center of the board. You will see these blink often. LED3 is the “WiFi Association” and LED4 is the “WiFi Connection.” The blue LEDs will blink each time the SCK posts new data wirelessly. This is normal behavior and is expected, but it only happens in bursts (then there will be no blue LED lit for about 30-40 seconds). If your blue LEDs are blinking back and forth non-stop, this means your SCK has lost its WiFi connection. Check to make sure your router is still on, and tht you’re still in range of it.
  • LED5 - This is the green LED in the upper left corner. It will be lit when the SCK is turned on and has power.

Let us know if you have any other questions, comments, or recommendations. Thanks,

-Matt
SCK 685

Thanks Matt for your answer.

Hi there, I am having a similar issue. I moved my SCK 2.1 to a new location so performed a factory reset and set it up as a new device. The device appears in my profile and can be viewd on the map with the correct location, and it says it is communicating OK, however it is not returning any sensor data via the smartcitizen.me site or via the API. Blue light is pulsing nicely on this end. Any ideas?

This is the device in question: https://smartcitizen.me/kits/9849

Does anyone have any suggestions here? I have been in touch with the support email address but it has all gone very quiet there too. I am at a loss here, having tried all sorts of resetting and reseating the sensor board in the main board.

Just adding some debugging information:
Here is more info on the kit from the API: https://api.smartcitizen.me/devices/9849
We can see that value and raw_value are null for all the sensors.
last_reading_at however gets updated, which means the Kit can talk to the API, but it is either not sending the sensor data, or there could somewhere be a wrong configuration.

This is the payload your device is sending:
"data":[{"recorded_at":"2019-08-07T13:04:19Z","sensors":[{"id":10,"value":-1}]}]}

It is only sending data for one sensor, the one with an id of 10
https://api.smartcitizen.me/v0/sensors/10

Yes, I have noticed that too. It is running off a USB power supply - could it be that this is under delivering in some way?

To be clear, it is running off USB power without any battery attached.

OK, so it was in fact a power issue. We tried replacing the uSB cable with a shorter length one and this has brought the sensors to life - thank you @viktorsmari1 for bringing this forward!
It was a hard one to debug as every other bit of the system seemed to be working fine, I falsely assumed it couldn’t be a power issue.

In the process we also re-registered the device. it is now 9875.

1 Like