Back to

No location and no data upload

Hi- I’ve seen the other posts and was wondering what is the solution that worked for establishing a location and correctly uploading downloading data?


Hello @polites,

A kit is not shown in the map if it hadn’t published data yet. I guess your problem is due to a configuration issue with your SCK.

Did the configuration process worked properly?

Please, reach us on if you keep having problems.

Hi Guillem.

Every time I set up the location, it saves and says updated and is all ok. However if I go back to the map to see if its there, it says the location hasn’t been set up. And I have tried to reset the location several times by moving the cursor on the map and saving…
I think this is an issue with the greatfire wall, even when I’m on vpn I can’t set the location. If its possible- do you know how other people in mainland china set up their locations?


Hi Polites,

As I explained on the previous threat: Your kit has a valid location but it will not appear in the map till it does post data on-line.

If you keep having issues connecting try to run the setup process again an ensure you are running the latest firmware version?

If you keep having problems please contact us directly on