Back to

Port is not appearing on drop down

I can’t get the usb port to appear when I try to configure my SCK. The java applet does run but no ports appear. I’m using OSX 10.8, Safari browser.



Hello Peter

maybe there is a problem with your Java version, try to get the latest one. Another thing to try is to use Firefox, it worked for me a few times.


Thanks, Tomas. I installed latest java version last night. I started with Firefox but it wasn’t showing any of the config options such as the dropdown menu as I saw in the video. Safari did show those.

Is Arduino necessary for the configuration? Or is that only if you want to program the SCK yourself.


Hi Peter,
Did you ever resolve this issue? I am having the same exact issue you mentioned. Would appreciate any suggestions - I also tried to manually configure but seems like that doesn’t work.

Are you a Mac? You need Java 7 and the very latest version’s security settings blocks unsigned applets. You need to go to System Preferences Java Control Panel and add the site. Then you will be able to run the applet.

My SCK has lost it’s settings and I’m having the same problem. The port drop down appears but it’s not finding the ports.

I’m stuck again too.

Unstuck. I was able to use Firefox to configure the SCK. I kept getting ‘unresponsive script’ messages but clicking ‘Continue’ kept it going. My SCK is transmitting data again.

Hello all

this issues are still being resolved, best way is to use Firefox and the latest update from Java. Security settings might need changes if Java doesn’t allow to access the ports. All this has been said before, just as a summary. A whole new registration process is being developed, we are delayed (As usual, apologies) but working on having a much more smooth process for this.