Back to Smartcitizen.me

Problems to configure SCK


#1

Hi

Around 6 months ago I tried everything with no success. Now I took it up again with same results. I just came across this forum and see that it may be a hw issue. I’d like some one to clarify if it is so.

My environment: Ubuntu/Firefox 30.0/SDK Goteo 1.0

What I tried:

  • Web registration tool: the process starts but it finaly fails when updating the firmware (codebender failure notice). That was last week, today I tried again and it doesn’t even promt to push the register buttom.

  • I configured manually the Wifly with the specific Wifly .ino file and MAC registration in the web tool. No effect, the router does not even see the board. Blue Lights blink all the time.

  • I loaded the Beta Firmware v.0.8.6 configuring the SCKBase accordingly. Same results.

During the firmware upgrades (both web and manual) I can see the orange leds working. I tend to think that the wify module is broken. In some other ocasions I had to refonfigure it because it used to turn up in AP mode, so I had to send commands to put it back as in client mode, register it again in the web and then all fine. But this time … no way.

I spent lots of time already. Please let me know if I should try anything else or how to proceed with the SCK. At least USB comunicaton goes fine and I could manually (IDE) upload and send commands.

Thanks in advance,
Roberto


#2

Hi Roberto, I am sorry to hear that after 6 moths you still having problems trying to configure your SCK. Just to be sure your SCK is ok, i wonder if you have already tried the SCK_check from the utilities folder!? You can find it here: https://github.com/fablabbcn/Smart-Citizen-Kit/tree/master/utilities Please, let me know how it goes. If this is ok we should try to find the problem elsewhere. I look forward to hearing from you soon. All the best.


#3

Hi guys,

I’m trying to re-configure my Smart Citizen Kit via browser, but I keep getting persistent “Codebender has crashed” issues on both Chrome and Firefox on OS X. Is it currently broken?

cheers,

Jani


#4

Hi @randomm, I have just finish configuring 7 SCKs using the Smart Uploader in our platform. Everything went smooth and without any issue. I am using Mac OS X 10.9.5 and Chrome v37.0.2062.124. Have you tried again since last Thursday!? Please, let us know. Best.


#5

Hi!

Yes I have tried. Via browser and codebender and Arduino IDE. Codebender crashes and Arduino IDE reports “Couldn’t find a Leonardo on the selected port when uploading…”


#6

Hi @randomm, It sounds to me like you did not choose the correct hardware version when trying to re-configure your kit and now your SCK’s bootloader is corrupted. Can you see your kit connected when you go to Arduino IDE’s “Tool -> Serial Port” menu!? Best.