Back to Smartcitizen.me

Resurrecting an old Smart Citizen Kit


#1

I’ve just found my Smart Citizen Kit that I lost several years ago.

It is a SCK Urban Shield v1.1 that I think I got around 2014. I recall at the time that it had issues with the WiFi.
Is there new firmware that I should install before trying to use the device again?


#2

So cool you are bringing you SCK to live again!

I will suggest you go to your profile page and then select “ADD NEW KIT” or click on the gear icon of the existing Kit you want to restart and select SETUP.

There using the configuration tool you will be able to update the FIRMWARE to the latest version. This is much most robust than previous versions. To upload the firmware you will need the Smart Citizen Chrome extension. This means you will need to use Google Chrome.

You can follow the installation guide here:

https://docs.smartcitizen.me/#/start/adding-a-smart-citizen-kit

If you are under Windows I will suggest you first check this:

https://docs.smartcitizen.me/#/start/how-to-install-the-drivers-on-windows

Also if you prefer to upload the latest version of the firmware manually using the Arduino IDE here you have the latest release:

Hope this helps!


#3

My kit is still listed under my profile from before.
Unfortunately the firmware won’t install via either Chrome nor the Arduino IDE.
In the Arduino IDE it compiles and uploads but nothing ever appears in the serial monitor.


#4

I’m in the same situation, and following this thread to see if there’s any way to revive the SCK.

I’ve uploaded new firmware – via web interface as well as manually using the Arduino IDE. It refuses to connect to WiFi.

I have a separate thread on the forum regarding my troubles with SCK from 2014, but figured it’s time to start afresh.

SCK MAC address : 00:06:66:21:8c:0e

EDIT : here is the serial debug

Wifi conection failed!!! Using ssid: Lumetronics and pass: xxxxxxxx
RTC not updated!!!
With no valid time it’s useless to take readings!!
Trying to get valid time…


#5

Hi @Anool

This seems to be a problem with your Wi-Fi router / ap. Here some suggestions:

  1. Try to move the Kit closer to the router maybe the signal is too weak

  2. Try to configure your Kit with a different network at work, on a friends house, or using your mobile hotspot…

Let us know how it works!


#6

Hi @andrew,

What OS are you using? Windows, Linux or Mac?


#7

Not if every other device I have (including ESP8266 units) connect to all of the different networks I have tried - one at home, another at work, a third at my maker space and my mobile as hot spot.
In all cases I was sitting practically next to the router.


#8

I’m using Mac OS 10.12.


#9

I’m having similar troubles. I have the kickstarter version, and is recognized over the serial port. It even updated its firmware. However, it will not connect to the WiFi. I added a hotspot (WAP) with an 18 character SSID and password (my main WiFi has much longer SSID and password). There are no spaces nor $ in the short WiFi SSID/pwd. Are there any other special characters or other silliness with SSID/pwd I should be aware of? In short, everything seems to work except the WiFi connect, which stops the install dead. I’m on a Win7 machine using chrome, if that matters.
Oh, and I’ve verified the WiFi by connecting to it via my phone and a tablet. What is happening under the covers? I presume the SSID/pwd is being sent by serial to the device and it’s trying to connect, but are you expecting a response thru the WiFi (back at headquarters), or just a response on the board? Is there a chance that an access point is the problem, and the device only works with a direct connection?
Any thoughts or suggestions?


#10

Exact same results on a Macbook/chrome with same network, so it’s not OS related.
It asks to reset or cycle power (after I tweak a value - reporting time usually), and just keeps trying to log in to the network, but complains it fails, then says it’s pointless to gather data since it can’t connect to a time server. lather, rinse, repeat. Getting pretty frustrated.

Any hints or thoughts about what I can do to coax this old kit back to life?


#11

more info, in case it is helpful -
✓ Saving wi-fy network settings…
✓ Update interval haven’t change!
✓ Settings synced!
✓ For your kit to work properly
✓ Please push the RESET button or simply turn your kit ON/OFF
✓ SCK >> Wifi conection failed!!! Using ssid: LINK_MR3040_123456 and pass: 112233445566778899
✓ SCK >> RTC not updated!!!
✓ SCK >> With no valid time it’s useless to take readings!!
✓ SCK >> Trying to get valid time…

— from “setup your kit” (step=2)
Port COM5 RESTART PROCESS

  • SmartCitizen Ambient Kit 1.1 - "Kickstarter Board"
    Firmware version 0.9.4 (latest) REINSTALL FIRMWARE

  • Mac Address: 00:06:66:21:b0:bd

  • Wi-Fi Networks ADD +
    LINK_MR3040_123456
    ••••••••••••••••••
    External antenna (not checked)
    WPA2 secured Wi-Fi

  • Update interval
    Sensor reading every 1 minute
    Publishing 1 post every 1 minute

SYNC SETTINGS

—Details of the WAP:

Operation Mode: Access Point
Name (SSID): LINK_MR3040_5DBC48
Channel: 9
Mode: 11bg mixed
Channel Width: 20MHz
Security: WPA2-Personal (AES or TKIP, neither work)
DHCP enabled: 10.0.0.150-10.0.0.199

Any of this helpful?


#12

Any more luck with this? I’m keen to bring my kit back to life for a project or do I just have to break it up for spare parts?


#13

I’m curious as well. Has anyone tried creating a wifi gateway that doesn’t require a password, just for testing purposes?

I stopped using my kit couple years back when the USB header decoupled from the board, but I’m curious if it would work again.