Back to

SCK 2.1 Noise sensor interval


We are making a project where one of our focus points is to gather higher density noise data. We have two reference sensors of the University of Ghent which work with a very high denisity.

And we’re planning a network of ~12 SCK sensors. I am playing here with mu test kit 2.1. I managed to finde the shell interval setting but I cannot set it under 60 seconds. The goal would be to have this sensor read at least every second. Any ideas? The publish interval can easily remain 1 minute. Only more data is needed.


Please share a detailed instruction of how to set a shorter then the default interval for the noise.

Hi @bron

Your project looks super cool!

At the moment, there is not a quick way to reduce the interval below 60 seconds

You might need to do this by directly editing the firmware.

@victor can answer you any questions while editing the source

Hi @pral2a,

I took a look at the github repo. Looks to me like a wild jungle. Sniffed around some files in sam/src as I expect this stuff will be somewhere over there. Honestly no idea where to bite at it. I am not a programmer (as of yet :slight_smile: ). Kind of hoped I will be able to just shell my way into this setting and I’ll be off the hook.

@victor I will be totally grateful if you lend me a hand with this. will be totally grateful too. We are fighting to get rid of a highway bridge. In the long perspective our government pledged to get rid of it and a lot of this is thanks to us “making noise” about it. Meanwhile before the big project comes (the preparations are ongoing) there is a 2 year refurbishment project starting (delayed because of the corona). The construction site is restarting this week. They will remove the noise screens and replace them with new ones. They will replace the asphalt and the section joints (very noisy). We’re trying to catch as much data as possible to know how much noise there was to begin with. How much will there be during construction and how much better will be thereafter. We have help of urban acoustic scientists of the university of Ghent. Their analysis and papers are supposed to be based on data which will be donated by our array.

Big chapeau’s for the entire SCK project. It has already been a huge enabler for many and we hope it will be one for us too.


Hi bron,

I will be happy to help you, my problem is time!
Reducing the reading interval for noise sensor is possible but we have to check that this doesn’t interfere with the rest of the functions, so i need to invest some time to check it.
If you are in a hurry there is another option, in the SCK shell there is a command called monitor that will get readings as fast as possible for the sensors you ask him.
The problem with this approach is that you can not send this data to the network, but you can save it to the sd-card! maybe that can work for you in the meantime?

Some instructions:

Connect to your SCK shell.
You can always ask for some help with the help command.

To get fast noise readings saved to your sd-card you need to do: monitor -sd -noms noise
the -noms option avoids writing the milliseconds passed between each reading.


and inside your sd-card you will find a file called MONITOR.CSV with the content:


To avoid interruptions while you’re trying this, put your kit in setup mode or issue the command shell -on.
The monitor command will keep getting data until you send any key or signal via the serial port or the kit is resetted (that includes any power interruption).

This command will get the readings as fast as it can, if you only ask for noise you will get around 5 per second with more sensors the frequency will be less. Remember no data will be posted to the network just to the sd-card.

If you need other sensors, you can include them in the command (comma separated) like:
`monitor -sd -noms noise, temp, pm10


The PM sensor will only update every 15 seconds and sometimes will fail to get readings in this mode, the rest of the sensors are expected to work. I you need to check the names of the available sensors you can issue the command sensor:


Hope this helps!!
As soon as i have time available will check the possibility of reducing the normal interval!


Hmm. Thx for the advice. Though weird.
I get a response “Not found is disabled, enable it first!!!” and the thing goes hanging. Not even on off button works. Only pulling the power brings him back.

Yes that message is a little buggy, it appears when the sensor is not found… what command are you using?

Exactly as specified by you “monitor -sd -noms noise”.

By the way Tomas D. from the Fablab team promised me that the support will contact me last week regarding ordering our 12 sets with enclosures. Given no answer from them since beginning of march I guess I will go and order from China and order the enclosures printed.

Hi Bron!

Please, understand we’re currently on a extremely uncommon situation due to the COVID emergency and our HQ at Fab Lab Barcelona are closed.

We haven’t yet contacted you because we haven’t yet a clear answer about when we’ll be able to return to our normal activity. I hope next week we’ll have more information about it and we’ll be able to reply you with a clear answer.


Yep. Yep. Same here. Understood. Nevertheless we will order on our own so that we can move on with this. No hard feelings.


Strange, for me this is the output (don’t pay attention to the values):


I’m sure you have the latest version of the firmware, but just to be sure can you check with the command version, SAM version should be 0.9.6.

The output you are getting get happens when your kit doesn’t recognize the word as a valid sensor, instead of noise try dBA.

Also try to use other sensors to see what happens, with sensor command you can see wich ones are enabled:


Ej, monitor temperature

When evaluating the command the kit is not case sensitive and it accepts as a sensor any part of the sensor title (ej. dbA) as long no other sensor has the same word on it.


Alright. Thx. I’ll try that in the evening and let you know.


Hi everybody, hi @victor,

Given the size of our project this method doesn’t seem feasible. The sensors are installed remotely at volunteers locations. Any chance on getting that firmware update allowing us to have denser noise readings?

See our project begin in this topic:

Super proud about this. Super enthusiastic. And once again huge kudos and thanks to Fablab and all contributors for the big enabler - the SCK. It will help fulfill the goals of our community. It will help to push the government of Flanders towards needed decisions. And the environmentalists and urban acoustic scientists at the University of Ghent are also excited about the data.


Hi bron,

Congrats on your project!!

I started working on an option for reducing reading intervals for noise in the firmware, as soon as i have something I will let you know!
Which is the desirable/acceptable interval for your project?


Hi Victor,

This is really good news for us. Our reference devices take multiple samples per second. It would be nice if we could end up around 1 per secon in the SCK. What is perhaps also interesting is to have more insight in the spectrum of noise.

Thanks for you precious assistance.


Hi @victor,

Any news on this?


Just for info
Maybe you already noticed but SAM 0.9.7 had been released about a month ago which among other things fixes:

  • Fixed bug that prevents per sensor intervals to work properly.
  • Updated noise compensation tables to improve readings on quiet environments.

Looks like this fixes the problems with the noise sensor :slight_smile: