Back to Smartcitizen.me

Setup issues. (SCK not responding! Try it again, please)


#1

I have spent about 5 hours today trying to get the setup to work. I have found this process to be incredibly frustrating. Please create 2 pages for setup with all setups from opening box to having it work. One for the old boards and one for the new. Having both referenced along with several ways to do various steps is very unclear. Having two separate docs and including lots of pics along the way and set for the most basic ways to do things would be a huge help to many I think. For an example check out the spark io project.

Anyway after successfully updating the firmware and installing the latest Java and using Firefox 64 bit on my Mac I got the setup applet to work. However at the end of the process I get a Mac Address but I also get a message box saying. “SCK not responding! Try it again, please” I have tried about 2 dozen times now with the same response two or three times with the board on top of my hub in case it was a signal issue. The green light is on. The blue lights are flashing once together then right then left then repeat. When running the setup the amber lights blink several times then just the blue as above. After 3-4 secs the Amber light again and the error message comes up. MY SSID is a two word one XXXXX XXXXXXX could this be causing issues?

Looking forward to getting this thing working. Thanks for any help.


#2

Having the exact same issue. The Java applet would only run on Firefox, and then I get the same SCK not responding error. Tried flashing the firmware via Arduino IDE, and got it to report sensor values over Serial, but still refuses to connect to my WiFi network.

This is really frustrating. In the time I’ve spent trying to get this to work, I could’ve built a better version that actually works for half the price using Arduino Yun and some cheap sensor modules!


#3

Sorry for the troubles with getting the hardware up and running. We’re putting together a short doc with snapshots of the process, thanks for the feedback!


#4

I have the same problem as described above. I created a single word named SSID and the configuration worked. So the problem seems to be two word SSIDs.


#5

It seems you need to use the dollar character “$” to replace any white space " ".
“My Awesome Password"
become
"My$Awesome$Password”

we are implementing it within the applet to be automatic.
As soon as possible we will post here updates on the topic.

Sorry for the inconvenience meanwhile.


#6

Hi Alexandre
I’ve jsut received the kit :slight_smile:
and unfortunetly ran into these same issues
is there an informal way to hack the kit into the registration and configure the wifi ?
even if it’s a bit complicated we could go through it


#7

same here, configging wifo doesn’t work; dissapointed !!


#8

Hi everyone,

We unfortunately know that the actual registration process is too dependant of the browser and Java version and configuration. We are actively working on (and fighting with) the next version of the online configuration. It will be based on the great work of https://codebender.cc/ and should simplify the process, while making it much more reliable.

We are also making a small tutorial explaining how to set the wifi settings directly trough the serial port (using the arduino IDE for example). Meanwhile, you can find on GitHub all the command available to configure your kit from the serial :

Don’t forget to register the mac address of your kit on the web platform. Without this step, the server won’t save the data coming from your kit !

Best


#9

NEW TUTORIAL ONLINE :
Manual Setup, the Serial way


#10

sorry, tried all methods. No serial response after $$$. Hardcodes wifi info in source; nothing. I’m very disappointed. please guys, you can do better

thanks

K


#11

Hi kamiel,
It is a bit difficult to understand your problem.
Can you see any serial message being plotted on the Serial Monitor ? Did you tried to turn off and on the kit while having arduino open and the kit connected ? have you double checked that you are in 115200baud and no line ending ?
did you succeed to upload the new firmware to the Arduino ? did you get any error ?
Please post as much information as possible.


#12

Bonjour Alexandre,

I’ve followed the instructions at http://smartcitizen.me/posts/view/10

and so far I’ve partially succeeded:

[snippet from the Arduino IDE Serial Monitor:]


CMD
get mac

Mac Addr=00:06:66:32:39:49
<4.00> set wlan key 3********5

Bad len=10
ERR: Bad Args

I can’t use a 10 characters for my WEP key?

I’m a semi-noob about wifi config, I am missing something?

[Update]:
Well… I figured this one myself… in the wiFLY module Roving Networks docs:

http://ww1.microchip.com/downloads/en/DeviceDoc/rn-wiflycr-ug-v1.2r.pdf

p.31


SET WLAN AUTH COMMAND AUTHENTICATION MODES
Value Authentication Mode
0 Open (Default)
1 WEP-128
2 WPA1
3 Mixed WPA1 and WPA2-PSK
4 WPA2-PSK
5 Not used
6 Ad hoc mode (join any ad hoc network)
8 WPE-64 (sic)


and p.33:


2.3.75 set wlan key
This command sets the WEP-64 or WEP-128 key, where is EXACTLY 26
ASCII chars (13 bytes) in hex without the preceding 0x. Hex digits greater than 9 can
be either upper or lower case. If you are using WPA or WPA2, enter a pass phrase with
the set wlan passphrase command.
The WEP key length depends on the WEP security used (WEP-64 or WEP-128):
• WEP-64 uses a 10-character key
• WEP-128 uses a 26-character key


more later…


#13

Hi Alex,

I get responses from the SCK (temp etc). But sending $$$ results in no response let alone i can config wifi by ‘set’ commands.

Tried hardcoding wifi param’s

#define redes 1
#if (redes > 0)
char* mySSID[redes] = { “Sitecom” };
char* myPassword[redes] = { “MyPasswd” };
char* wifiEncript[redes] = { OPEN }; //OPEN, WEP, WPA1, WPA2, WEP64.
char* antennaExt[redes] = { INT_ANT }; //EXT_ANT
#endif

(wpa2 and open networks) but no connection:
(repeased indef.):

SCK Sleeping…
SCK Waking up…
updates = 1
Error in connectionn!!
SCK Sleeping


Temperature: 24596 C RAW
Humidity: 33184 % RAW
Light: 322.5 lx
Battery: 100.0 %
Solar Panel: 0 V
Carbon Monxide: 197.132 kOhm
Nitrogen Dioxide: 1.735 kOhm
Noise: 112 mV
Wifi Spots: 112
UTC: 2000-01-01 00:01:17