Back to

[SOLVED] Platform doesn't show / register newly published data

i tried to publish data from my SCK to the platform. But unfortunately the data never gets shown on the platform. The log looks good so far, but nothing happens on the platform. Does someone have an idea what could be wrong?

Temperature: 24.40 C
Humidity: 53.55 %
Battery: 76 %
Light: 140.65 Lux
Noise dBA: 48.82 dBA
Barometric pressure: 101.82 kPa
VOC Gas CCS811: 1220.00 ppb
eCO2 Gas CCS811: 2238.00 ppm
PM 1.0: 0 ug/m3
PM 2.5: 0 ug/m3
PM 10.0: 0 ug/m3

(2023-02-19T12:18:47Z) Readings saved to sdcard.
(2023-02-19T12:18:47Z) Sent 11 readings to platform.
(2023-02-19T12:18:47Z) Published OK, erasing from memory

This is my config:

########## (sensitive data was replaced by xxx
Mode: network
Publish interval: 300
Reading interval: 60
Wifi credentials: xxxxxx - xxxxxxxx
Token: xxxxxx
Mac address: 3E:71:BF:30:54:62

Hardware Version: 2.1
SAM Hardware ID: 46051ED050515157382E3120FF14203D
SAM version: 0.9.1-30e1776
SAM build date: 2019-05-07T02:45:29Z
ESP MAC address: 3E:71:BF:30:54:62
ESP version: 0.9.0-0aee873
ESP build date: 2019-05-06T20:27:10Z

Update to newer firmware didn’t change anything


Temperature: 24.17 C

Humidity: 51.32 %

Battery: 86 %

Light: 295 Lux

Noise dBA: 41.22 dBA

Barometric pressure: 101.86 kPa

VOC Gas CCS811: null ppb

eCO2 Gas CCS811: null ppm

PM 1.0: 0 ug/m3

PM 10.0: 0 ug/m3

PM 2.5: 0 ug/m3

(2023-02-19T12:45:42Z) Readings saved to flash memory.

(2023-02-19T12:45:42Z) 9 readings saved to sdcard.

Connecting to Wifi…

ESP finished booting

Connecting to Wifi…

Connected to wifi!!

(2023-02-19T12:45:42Z) Sent readings to platform.

Network publish OK!! (9 readings)

Hi @gerd

Sorry for the issue and for not replying sooner, let’s see what we can do: can you paste here the device id?

thank you for picking up this issue. The Hardware ID is

SAM Hardware ID: 46051ED050515157382E3120FF14203D

I hope this helps.

Best regards,

Hi @gerd

Sorry, I mean the device id, as in the number after:



sorry, here it is:

Best regards,

HI @oscgonfer, is this the number you were asking for?

Best regards,

Hi, yes
Will PM the token.

Solved! The issue was the ESP firmware version.