Back to Smartcitizen.me

Temperature sensor anomaly


#1

Hi,

I’m scratching my head trying to figure out why, nearly ever night anywhere from 11pm to 1am, there’s a brief daily spike in temperature. Seems like the average temperature is somewhere in the range of 10 to 12 degrees Celsius, but at 11pm, it spikes to 88 degrees Celsius and then settles back down to 10 degrees. The SCK is relatively isolated. It’s not near a heat source.

Anyone else having this happen?

Thanks,
Chris


#2

I get daily spikes, yesterday’s shot up to 124.5º (((and I’m sure it’s not that warm here))) but I can’t find a pattern.


#3

That’s a significant spike.

Seems like from what I’ve seen, it’s at least once a day. I wonder if there there’s some process running that’s generating extra heat on the board.

Are you connected to the battery pack or through USB into a laptop?

Cheers,
Chris


#4

I thought of 2 possibilities :

  1. it happens when, like you suggest, I’m plugged into the USB port (which recently snapped off, so I know longer have that problem).
  2. the card, which was posed on the window sill, was getting directly heated by the sun.

#5

Looking at this, anyone else having the same problem? the ones we are testing seem to be ok, will check firmware issues, if yes all could be solved with the new version of firmware coming soon, totally able to be upgraded to platform, no need of Arduino IDE. Apologies for the lack of speed on responding


#6

Hola,

I’ll upgrade to the new version of firmware test and post the results. Thanks for your response.

Chris


#7

Ok, just to check: are you using the latest one posted on the forum in announcements?


#8

I am using version 0.8.5 that I downloaded on January 26th. This is the version I should use?


#9

Hi,

I just want to make sure I’m clear on the steps I need to take.
Can you tell me the steps for a clean install of the new firmware?

Would I upload the new firmware files to the Arduino IDE and then run the configuration step in the browser? Or would I leave the existing code running and just run the configuration step again?

Currently, I have 0.8.5 installed for V1.1 Arduino LilyPad USB using the Arduino IDE and the Java applet running through the firefox web browser.

I do still get script errors while trying to configure the SCK.
I sent an email to the support email address with screenshots of the script error messages.

The browser displays that the configuration process completed successfully, despite the error messages.

Thanks,

Chris


#10

With v0.8.5 flashed I too am getting spikes: http://smartcitizen.me/devices/view/476

The two spikes today may correlate with turning the USB power off then on.


#11

I re-installed v0.8.5 and I’m still getting temperature spikes.

Could the spike be caused by the USB cable? Suppose I could test out a couple scenarios.


#12

Here are some of the strange humidity and temp values I’m getting.

timestamp hum temp
2014-02-05 13:19:02 , 1156.8, 2410.8
2014-02-11 02:21:12 , 1196, 2378.8
2014-02-10 10:31:39 , 1244.4, 2373.6
2014-02-10 22:02:02 , 1248, 2352.8
2014-02-05 23:37:34 , 1408.8, 2307.6


#13

Still getting them here http://smartcitizen.me/devices/view/476 and they’re completely messing up the display of data.

Very frustrated by the lack of help.


#14

Have you tried it with the battery? Do you get the same output? I think when I used just the battery the temp and humidity values were in an acceptable range. I think I’m going to switch and just use the battery. Is there a USB and Arduino heating issue?


#15

Yep, I have the battery and USB plugged in, essentially using the battery to cover any power outages. Having to mess around with the battery is far from ideal, but I’ll give it a go.


#16

Ok here’s something worth checking into.

http://www.australianrobotics.com.au/news/fuelling-your-arduino-why-you-should-use-an-external-power-breakout


#17

So, even on battery only I’m still getting spikes. I’d post the data but the api won’t list it for some reason.


#18

Good to know!!

I switched from using an old laptop usb to a Raspberry Pi, and still getting spikes.

Next, I think I’m going to wipe everything clean and then re-install the firmware. However, I’m starting to think I have a faulty board because I had this issue from the beginning.


#19

I’ve done the re-write multiple times. I’m thinking of throwing it in the bin and building my own.


#20

Here’s some info I received today from Acrobotic Industries.

"What I’ve learned from the online platform developers is that the spikes are caused by
errors on the streaming of the data (such as the server missing a
reported data point) rather than your sensor going haywire for a brief
period of time.

The developers are in the process of migrating the database from a
SQL- to a NoSQL-type in order to mitigate some of the problems users
have experienced (including the noise you’re reporting).

If you want to troubleshoot a bit more, you can always open up the
Arduino IDE. Then use the Serial Monitor to have a look at the raw
data being streamed directly from the sensor."