Back to Smartcitizen.me

Usb port dead


#1

yesterday i just uploaded a slightly modified version of sck_beta_v0_8_6.ino :

`
diff Smart-Citizen-Kit-0.8.6/sck_beta_v0_8_6/sck_beta_v0_8_6.ino \
Smart-Citizen-Kit-0.8.6/sck_beta_v0_8_6-modified/sck_beta_v0_8_6.ino
39c39
< #define wiflyEnabled true

#define wiflyEnabled true // changed
42c42
< #define debuggEnabled false


#define debuggEnabled true // changed
59c59
< boolean terminal_mode = false;


boolean terminal_mode = true;// changed
`

and after that the device /dev/ttyACM0 was gone and never appeared again. there also was no /dev/ttyACM1 or anything.
not even a single message at dmesg when disconnecting and connecting usb again. switching the device on and off again. disconnecting the battery and usb, resetting it with its reset button (the button at the usb connector), …

total silence at dmesg. i fear that somehow the usb connector is broken or worse.

somehow the device is still working. i see the two blue leds blinking as usual. i still can connect over the wifi access point via telnet:

tom@antyr:~$ telnet 1.2.3.4 2000 Trying 1.2.3.4... Connected to 1.2.3.4. Escape character is '^]'. *HELLO*

… but it remains that way for long time (40minutes now) without any further messages.

the usb connector looks ok. there also was no physical impact or anything like this.

please help!

tom.


#2

What you programmed as Lylipad Arduino USB or Leonardo? If as Leonardo was and is a sck 1.1, you’ll have to reprogram the bootloader. Because it no longer appears in the list of devices.


#3

Lylipad Arduino USB as always.
how can i reprogram the bootloader?

do i have to use another software like you suggest here:
http://forum.smartcitizen.me/discussion/comment/422#Comment_422

this one looks like one has to buy it:
http://www.atmel.com/tools/avrispmkii.aspx

thats why i would prefer this way:

http://forum.smartcitizen.me/discussion/comment/422#Comment_422

but i am not sure about what exactly to do. can someone please explain the process?

thank you!

tom


#4

Hi @tomscherl,

I am really sorry to read that you are having problems.

As @mdeheras said on his previous message, all this uploading issues can be fixed burning the bootloader again.

Burning the bootloader is a quite simple operation but you need a ISP programer as the Atmel AVR ISP Mk2 (http://www.atmel.com/tools/avrispmkii.aspx). Or you can also use another Arduino as an ISP programmer (http://arduino.cc/en/Tutorial/ArduinoISP).

Bootloader corruption problems is one of the most common issues we are facing so we are already working on a tutorial (among many others) on How to use and Arduino as ISP programmer with your SCK. We hope to have it ready before the weekend, so I will get back to you as soon as it is available.

My most sincere apologies for any inconveniences this may cause.

All the best.


#5

hi again,

yesterday i met some nice guy who explained me how to burn the bootloader with a 2nd arduino (based on http://arduino.cc/en/Tutorial/ArduinoISP and other sources) :

i will try to describe the process as far as i understood:

on the top of the arduino there are 6 pins in two rows right below the heart (with -+ inside). those pins are labeled with “ICSP-A” this is the place where the other arduino has to be connected via brazed cables:

the pins have the following pin-configuration (i numbered them from left to right looking at it so that the labels can be read):
http://schwae.ddns.net:10080/gallery/index.php/arduino/2014-07-02_07-57-33

123 456

1 ... reset 2 ... clock 3 ... MISO 4 ... GND 5 ... MOSI 6 ... +

please correct me here if i am wrong!

now to the programmer arduino. here i have a foto of the arduino i would like to use as “programmer”:

http://schwae.ddns.net:10080/gallery/index.php/arduino/2014-07-02_08-14-21
(only online between

those 6 pins have to be connected to the other arduino ( the programmer ) in the following manner:

1 ... reset ... D10 2 ... clock ... D13 3 ... MISO ... D12 4 ... GND ... GND 5 ... MOSI ... D11 6 ... + ... + (3.3V?)
http://schwae.dyndns.org/gallery/index.php/arduino/2014-07-02_20-57-06

if all pins are connected. the programmer arduino should be connected via usb to your computer.
no the following steps have to be done (folowing
http://arduino.cc/en/Tutorial/ArduinoISP)

  • start arduino ide.
  • select serial port
  • select board of programmer (in my case “arduino pro 5v, 16MHz”)
    [ * select Tools => programmer => arduino as ISP ]
  • Upload the ArduinoISP sketch (File => Examples => ArduinoISP )
  • select board for smartcitizen arduino ( in my case: Tools => Board => LilyPad Arduino USB )
  • check wiring as described above (foto follows)
  • Tools => Burn bootloader
  • disconnect wires ( at least ground and + )

your smartcitizen should work now again. you should be able upload a smartcitizen firmware now again after connecting it to usb and switching it on.


#6

hmm… i just followed those instructions:

http://arduino.cc/en/Tutorial/ArduinoISP

but the arduino seems still dead. the only led thats on is beside the power button. :-/


#7

YEZZ!! it worked. just forgot to disconnect the ground pin. :smiley:
so ill complete the simple description above. maybe someone else faces the same problem.

thanks people and special thanks to robelix from it-syndikat.org :wink:


#8

@tomscherl: The SCK works @3,3V so NEVER NEVER NEVER connect your SCK’s ICSP Vcc pin to Arduino UNO’s 5v pin. Use always the 3,3V pin of the Arduino UNO. Best. :slight_smile:


#9

i have different sources telling to connect icsp + to 5V:

http://arduino.cc/en/Tutorial/ArduinoISP
(images show a connection to 5V


“Connect pin 2 of the ICSP header to your +5V supply”
…and others…

and also… i actually connected + to 5V and it worked. but probably you are right and i was just lucky that nothing bad happened.


#10

If you connect to the ICSP pin VCC to 5v, you can damage the wifi module, since this works at 3.3v.