Back to

WiFi won't connect to my network


SmartCitizen Ambient Kit 1.1 - "Kickstarter Board"
Firmware 0.8.6.


The board will not connect to my router, blue led3 and blue led4 keeps blinking back and forth.

Hi @nfitzpatrick! Can you give more info about you did configure you SCK!? Did you used the Smart Uploader!? Did your hardcoded the network credentials? Unless there is a problem with your wifi module or your router, you should be able to connect. I look forward to hearing from you. Best. :slight_smile:

@aitoraloa I used the updater (via FireFox) - and entered the wifi credentials there as well. The kit is showing that the correct network credentials has been stored, but it will not connect.

I have other wireless devices (g, and n) all connecting to the network fine.

When i first go the kit it was connecting to the network (intermittently) then stopped, i thought that the 1.1 update was meant to address the WiFi problems. Now no connection at all - just the blue led3 and blue led4 keeps blinking back and forth.

@nfitzpatrick: when the blue led3 and blue led4 keeps blinking back and forth is because the SCK is trying to connect to a network but it can not. Have you tried the sck_check from to examine if the wifly is ok!? Have you check what does it appear on Arduino IDE’s monitor serial when restarting your device!? I normally use Chrome to configure the kits but Firefox should works also fine. I would tell you to try the manual compilation mode: Please, let me know how it goes. :slight_smile:

My network is fine, as i mentioned in my earlier post the board was working intermittently when I first received it, the 1.1 update made it completely useless!!!

Hi @nfitzpatrick,

I just messaged you about your SCK.


Hi folks,

it seems I have the same problem. I tried hardcoded in the Arduino IDE and via smart uploader.
When I check with the commands on the serial monitor SSID, pass phrase and so one seems correct. But it does not connect to the network at all.
Only firmware is in my case 0.9. Any idea what can be wrong?
I tried on several different networks all with WPA2. I also tried SSIDs and pass phrases completely without any special signs (like '#+* and so on) only with letters and it still did not work.

Greetings Sven

Hi @sven22,

Could you confirm this is fine?

I will suggest you after to give it a last try by going using the on-line tool since we keep improving the firmware continuously.

Let me know how it works!