Back to Smartcitizen.me

WLAN no longer working (no activity on LEDs)


#1

Hey folks,
my kit was inactive for about 22 months. I tried to operate it by solar panel but there is not enough sun here.
Today I tried to switch to usb power but the kit no longer sends any data.

Problem: no blue LED activity is visible.
What works: green power led, orange activity LEDs when connecting via USB to PC.
I uploaded the latest firmware via chrome browser (and extension) and successfully set up my wlan (successful according to protocol). Still no blue LED activity visible and still no data after 15 minutes of waiting.
BTW: the setup process shows the correct MAC so the wifly module might work as expected (?)

I then installed Arduino SDK and kicked up the Serial Monitor.
This is the output (repeated every minute with updated values):

SCK Waking up…
Error in connectionn!!
SCK Sleeping


Temperature: 27508 C RAW
Humidity: 23900 % RAW
Light: 12.60 lx
Battery: 100.00 %
Solar Panel: 0 mV
Carbon Monxide: 465.77 kOhm
Nitrogen Dioxide: 27.23 kOhm
Noise: 0 mV
Wifi Spots: 0
UTC: 2000-01-01 00:02:34

Any SCK command I send via Serial Monitor seems to work fine.
Then I tried to enter some of the wifly commands but there is no response. never.

I tried to update to the beta 0.9.2 but still no success.
Is there any command to see that the wifly module works correctly?
I have found some reference to wifly firmware updates but I did not find any specific howto or other resources.

I am not that deep into arduino programming so I am not sure whats wrong when I get the message "Error in connectionn!!"
SCKBase.cpp -> connect() does not (debug-)output any helpful information.

Do you have any hints for me? Might it be a hardware problem? Any other ideas?


#2

Hi @seafoxx,

thanks for your detailed overview of your issue.

At a first glance this seems it could be an issue linked to a bug on the previous WiFly firmware release. This was fixed by Microchip a long time ago and our Arduino firmware is able to automatically upload the module with the latest release but let me check with our technical team and I come back to you with more details…

Thanks


#3

I own a SCK Base Board v1.1 and an urban shield v1.1.
The WiFly Chipset contains the following text:
RN131G-I/RM
Model: G2M5477 (02.6)
IC: 8169A-G2M5477
AS i already mentioned: the chrome-based setup process shows the correct MAC so the wifly module seems to respond somewhat.
Tell me if you need more info. I did not find any specific instructions on how to upload / update to the latest wifly firmware. the chrome-based setup process seemingly succeeded.

best regards
Bastian


#4

Hello @seafoxx,

we just launched a new version of the configuration tool last week.

Could you please have it another try?

For any questions you might also check here

http://docs.smartcitizen.me/#/start/adding-a-smart-citizen-kit

Regards


#5

Hey @guillem,

thanks for the heads up. I tried the new configuration tool but with no success.

This is the output of the message box (tried it several times, this is the result of one of the update processes):

✓ Please, reset your kit by pressing the reset button or switching it off / on.
✓ Once reseted, select your SmartCitizen serial port and click Start process…
✓ Connected ports: /dev/cu.Bluetooth-Incoming-Port,/dev/cu.NadinesMacBookAir-Bluet
✓ Connected ports: /dev/cu.Bluetooth-Incoming-Port,/dev/cu.NadinesMacBookAir-Bluet,/dev/cu.usbmodem1421
✓ Your kit is a SmartCitizen Ambient Kit 1.1 - "Kickstarter Board"
✓ Your kit is running 0.9.3. This is the latest version.
✓ You can skip the firmware update!

=> klicked on “update firmware”

✓ Updating your kit to the latest firmware…
✓ Clearing eeprom memory…
✓ Firmware uploaded!
✓ Your kit is a SmartCitizen Ambient Kit 1.1 - "Kickstarter Board"
✓ Your kit is running 0.9.3. This is the latest version.
✓ You can skip the firmware update!

=> set up the wifi and update intervals

✓ Saving wi-fy network settings…
✓ Update interval haven’t change!
✓ Settings saved!
✓ Please, reset your kit in order the changes to take effect!

=> switched the board off and on again

✓ Connected ports: /dev/cu.Bluetooth-Incoming-Port,/dev/cu.NadinesMacBookAir-Bluet
✓ Connected ports: /dev/cu.Bluetooth-Incoming-Port,/dev/cu.NadinesMacBookAir-Bluet,/dev/cu.usbmodem1421

still no wifi action…

when switching on only the green power LED 5 is permanently on, orange LED 2 flashes short once.
during the update process both orange LED 1 and LED 2 flashes several times.
no action at all on the blue LED 3 and LED 4.

Do you have any further advices? Do you have a diagnostics firmware that outputs anything useful?

best regards
Bastian


#6

As there is no progress and no more tips/tricks how to at least diagnose the problem, I’ve pre-ordered a new unit :-/
Hope it still fits into the grey housing unit I got with my kickstarter board.


#7

Please,

contact us on support@smartcitizen.me in order we can set a remote support session

We are really sorry for the issue