Back to

Data not reaching the server?

Hey there,

Recently, when resetting the kit for adding a new GPS module, I have found that the data my kit is producing is not reaching the server (or at least that seems so), yet it shows the corresponding messages of communication success.

I’ve tried via the API but again the state is “never_published” and there is no data available.

What the kit says…
I activated the ESP debug flag and it all seems working fine, however, the data must not be reaching the server successfully…

Kit info
ID: 14061
Hardware Version: 2.1
SAM Hardware ID: 80D5E9DF5054414B352E3120FF17202C
SAM version: 0.9.7-be3ffb0
SAM build date: 2021-02-25T10:42:50Z
ESP MAC address: 4A:3F:DA:09:C3:A3
ESP version: 0.9.3-8b3c4e0
ESP build date: 202{

What have I tried?

  • Resetting the kit to defaults → no data upload
  • Explore the forum → I found topic #1540 and topic #1272 but neither had any useful insight for me
  • Ask the support team → I was warned that the web interface doesn’t accept GPS data to be displayed but these shouldn’t affect the API records
  • Check internet connection → connection is OK


  • What should I do?
  • Is there anything that is impeding my kit reach the server?

Thanks in advance,


Thanks for the detailed report. I believe it’s a simple problem of versions.
Could you post the output of the config command in the terminal (please, blank out the Wifi Password)?

Data should arrive, if the proper token is set, and if the blueprint is right, for both, air and GPS data.

If you prefer, you can also drop an email with the info to and I will take care of it.


Thank you @oscgonfer !

I’m reaching you by email then


1 Like