Back to

My SCK doesn't appear on the web


I have three SCKs. All of them are configured and connected to wifi network. However, the web interface doesn’t locate my kits on the map and saids “Your kit has still not posted any data.” What can I do to fix the problem? Any advices are welcome.

The URL of (one of) the kit is
I also put the log data as follows:

Temperature: 23.00 C
Humidity: 56.52 %
Battery: -1 %
Light: 17 Lux
Noise dBA: 48.46 dBA
Barometric pressure: 101.69 kPa
VOC Gas CCS811: 11.00 ppb
eCO2 Gas CCS811: 476.00 ppm
PM 1.0: 0 ug/m3
PM 2.5: 0 ug/m3
PM 10.0: 0 ug/m3

(2019-10-15T15:53:48Z) Sent 11 readings to platform.
ESP --> Receiving new readings…
ESP --> Trying MQTT publish…
ESP --> Connecting to MQTT server…
ESP --> Established MQTT connection…
ESP --> device/sck/llw2ov/readings
ESP --> ␂device/sck/llw2ov/readings
ESP --> MQTT readings published OK !!!
(2019-10-15T15:53:48Z) Published OK, erasing from memory




I solved the problem and found a bug on the ESP firmware. While the flag for debug is set as bool serialDebug = true;, the variable netBuff[] is somehow overwritten. It collapses JSON data for mqtt communication.


1 Like