Back to Smartcitizen.me

Death by night


#1

Dear Community,
my SCK died again around midnight:


Even with the sunlight now, it doesn’t wake up (resurect) again!
What can I do?
Very best regards
Klaus


#2

You can give the reset button?


#3

You might have bricked your Wi-Fly (wifi) module - see the other threads. Check your Wi-Fi access points from a wireless computer. If you have one named SCK_98 your Wi-Fi module is bricked and only runs the Web-Config inside it.

But the SCK will never (with current power usage) last 24 hours even with full solar power. No matter how I change the firmware - I’t wont charge/use more than 350 mA. The SCK uses 100 mA on average. That leaves 250mA of charge capacity pr hour.

Battery is 2000 mA - so you need at least 8 hours of full sunlight. But then the heat sensor stops the battery from charging from time to time. So for me in the Middle East with 10-20 degree temperature difference between day and night - the temperature sensor disables charging for 4-7 hours out of the 6-10 hours available. So if I’m lucky I get 5 hours of real charging = 1250 mA.

So as I have said before - the charge circuit is wrong - and it should charge at much higher rates - and battery should be 6000 mA vs 2000 mA to last a couple of days without sun. But that is just standard solar calculations you make (or are supposed to make) when you design a product. Sorry to sound like sour grapes but all these issues should have been discovered long time ago - before shipping.


#4

Thank you very much for your comments!
@mdeheras I had to reset the device by hand (!) to reboot (?) to get back to normal.
@kaz911:
I had to look up “to brick” :slight_smile: !
Actually, no: after the reset, it’s transmitting data again.
I also think that the charging mode is not at its best…

How can I make it auto-rebooting (in sunlight)?

Cheers Klaus


#5

@Klaus: this is an error that occurs from time to time and we are trying to find the reason why. It could be the code or the wifly’s latest firmware version. Anyway, with Microchip’s latest upgrade, the WiFly should work fine. If you have the latest version of the firmware on your WiFly module, this should not happen to you. Best. :slight_smile:


#6

How can I check the version of my WiFly-module?
What is the latest version, though?
Updating the SCK, means updating the WiFly-module as well?


#7

Hi,

Using any serial terminal to connect to your SCK via USB.

Then to check the Wi-Fly - enter $$$ (enter) - that will bring the Wi-Fly into command mode. If you then just do a ls (enter) - it will show you the files on the flash drive. It should then show wifly-GSX- Version Number or something like that :). The old one shows “wifly-GSX-400” - I think the newer firmware should show “wifly-GSX-441” i think.

when you are done - write exit (enter) and the wifly module will reboot.


#8

all right (never done that before…)
Thank you @kaz911 !
I’ll be back…

–> but: latest firmware can be only 4.00 !?
and:
4.00.x 2013-05-01 Not recommended for new designs

https://www.microchip.com/pagehandler/en-us/products/wireless/home.html?tab=t2

any idea why?


#9

The latest version is 4.41, is on page 107 of the datasheet, when you upgrade to the latest firmware version SCK (0.8.6) , we force the module is updated to 4.41.

http://ww1.microchip.com/downloads/en/DeviceDoc/50002230A.pdf


#10

We managed it!
I do already have the latest update. (4.41)
SCK is on 0.86 now.

Will it wake up on it’s own now???
Klaus


#11

How can I load the newest version 4.41 manually? I can install the newest SCK version (0.86) with the web installation (sandbox) but the files on the flash drive are still old, i.e. wifly-GSX-400. Where can I find the newest version wifly-GSX-441 and how can I load it?
Many thanks for any help

Stefano


#12

Ciao Stefano!
What I did was:
a) loading a software called “Serial Port terminal” https://apps.ubuntu.com/cat/applications/oneiric/gtkterm/
b) Connecting via USB and setting the correct port
c) figuring out, that I might have already put the 4.4.1 on via the “sandbox”-Website (http://sandbox.smartcitizen.me) and the configuring process there.
–> lucky me, can’t find download-link for the 4.4.1 either!


#13

My SCK woke up on it’s own! :slight_smile: !


#14

@kaz911 you wrote: “You might have bricked your Wi-Fly (wifi) module - see the other threads. Check your Wi-Fi access points from a wireless computer. If you have one named SCK_98 your Wi-Fi module is bricked and only runs the Web-Config inside it.”

I have exactely this situation: only web_app running and I see a Wi-Fi access point called SCK_98. The configuration via sandbox to 0.86 doesn’t update the wifly module :frowning:


#15

Hi @Stebar59! :slight_smile:

You could try to upgrade your WiFly module via the Arduino IDE. You just need to download the sck_beta_v0_8_6 from here: https://github.com/mdeheras/Smart-Citizen-Kit/tree/develop. Open the sck_beta_v0_8_6.ino file. Then add the network (and the password) you are going to connect in “SCKBase” tab:

#define redes 3 //Number of networks
#if (redes > 0)
char* mySSID[redes] = {
“yournetworkhere” , “Red2” , “Red3” };
char* myPassword[redes] = {
“yourpasswordhere” , “Pass2” , “Pass3” };
char* wifiEncript[redes] = {
WPA2 , WPA2 , WPA2 };
char* antennaExt[redes] = {
INT_ANT , INT_ANT , INT_ANT }; //EXT_ANT
#endif

Once you upload the firmware (remember to choose LilyPad Arduino USB as your Board) you can open de serial monitor and check how the process. If it says “Upload failed”, reset (or off/on) your SCK and open the serial monitor again. Sometimes it says “Failed” but the update is done. You can check if you have the last version of both firmwares (SCK and Wifly) writing “get sck info” and “get wifi info” in the command line.

Let me know how it goes, please.

Best, :slight_smile:


#16

Hi aitoraloa,
I’ve downloaded the sck_beta_v0_8_6.ino from your github site and loaded it to the SCK via Arduino IDE. It loaded fine without errors.
I entered the commands as you sudgested and here what I receive:

“get sck info” returns: 1.1-0.8.6-A
"get wifi info" returns: 0

When I enter $$$ in the command line I receive: Please, wait to wifly sleep
and then nothing happens. If I enter a second time $$$ it enter WEB_APP-1.06 mode and I can for example list the files in the memory, i.e.

<WEB_APP-1.06> ls

FL# SIZ FLAGS

2 86328 23 wifly-GSX-400
4 74920 3 web_app-GSX-106
7 46632 3 wps_app-GSX-131
9 66240 3 eap_app-GSX-101
11 37282 0 web_config.html
21 512 0 link.html
22 7268 0 logo.png
24 -1 10 config

169 Free, Boot=2, Backup=2

I’m reporting here some output from the web_app commands:

<WEB_APP-1.06> ver
WiFly WebConfig v1.06 Apr 19 2013 11:48:44 on RN-131

<WEB_APP-1.06> scan
SCAN:Found 5
01,01,-72,04,3104,18,c0,9c:c7:a6:21:7d:a3,xxxxxxxx
02,06,-71,00,2104,00,00,84:34:97:30:ff:7b,xxxxxxxx
03,06,-63,04,1104,1c,c0,dc:0b:1a:c2:b8:19,xxxxxxxx
04,11,-60,04,3104,1c,00,f8:1a:67:82:f3:5c,xxxxxxxx
05,11,-71,04,1104,1c,40,8c:04:ff:14:de:b2,xxxxxxx
SCAN:END

After the command exit the SCK start displaying this data:

SCK Waking up…
4 0
Error in connectionn!!
updates = 1
Saved in memory!!
SCK Sleeping


Temperature: 27792 C RAW
Humidity: 21240 % RAW
Light: 169.2 lx
Battery: 100.0 %
Solar Panel: 0 V
Carbon Monxide: 266.778 kOhm
Nitrogen Dioxide: 22.382 kOhm
Noise: 97 mV
Wifi Spots: 0
UTC: 2000-01-01 00:16:29


… and so on!!

I really don’t know what to do now!! I’m at a dead-end!!!
I think my SCK is broken.


#17

Another try …
I downloaded the Wifly_update from your github, entered my Wifi data in SCKBase and loaded into the SCK.
The serial output is showing nothing for 1 minute and the it show the <WEB_APP-1.06> prompt!!!
I don’t think the Wifly module is updated!!!

I’ve also loaded the Wifly_Rescue sketch and in this case the output show me:

Reseting…
Successfully reset

and the the <WEB_APP-1.06> prompt!!
Looking at the files in the memory I still see the old files:

FL# SIZ FLAGS

2 86328 23 wifly-GSX-400
4 74920 3 web_app-GSX-106
7 46632 3 wps_app-GSX-131
9 66240 3 eap_app-GSX-101
11 37282 0 web_config.html
21 512 0 link.html
22 7268 0 logo.png
24 -1 10 config

169 Free, Boot=2, Backup=2

PLEASE HELP ME!! I’ve really no more ideas!!!


#18

Write “set boot image 2”, if returns fail, the wifi module is corrupted.


#19

set boot image 2 … say me AOK
But is wifly-GSX-400 not an old version of the file?


#20

Sorry, is “boot image 2”