Back to Smartcitizen.me

Light sensor reads 0

Finally got my SCK up and running.

The light sensor does not seem to be working. Other sensors on the web have values. Anybody have an answer why mine reads 0? It was in a lot of sun today and the temp jumped but still no light reading.

Peter

Hi,

It’s Chris, if you want maybe we can meet up, and we can try and configure the board on my laptop. I’d be interested to see if this work.

Same thing here. Seems a bug. I tried a better PSU and moving SCK 2.1 closer to AP and even a factory reset and reinstall, all to no avail.

We’re looking at this issue, and we’ll write you back soon!

We keep working on the firmware intensively to provide a new software release soon, fixing bugs and adding new features.

Meanwhile, I’m not sure about PM values. I need to take a closer look but compared to two luftdaten.info SDS011 sensors mounted neaar the SCK there seems to be factor 10 involved i.c. SCK PM data are a tenfold of these from luftdaten. However, this observation is based on only one or two PM measurements so it is very, very premature.

I have the same issue … https://smartcitizen.me/kits/9487

Hi,

We have been testing the PMS5003 in co-location with the SDS011 sensor and they give quite similar results in PM2.5 - PM10 values. Both sensors are based on a very similar principle (Light scattering sensor based on particule counting - more on this in some days in the docs).

You can see a comparison of the sensors in the image below for both metrics (R2 > 0.8).

It seems though, that the PM2.5 from a PMS5003 is a bit higher, but that is highly dependent on the internal math of the sensor. At the end of the day, what these two sensors do is just count particles that cover a laser beam. Then, with an estimate of the average particle density, shape factors and so on, they calculate volume and mass (PM). Each sensor could have different internal estimations and behave better with different types of particles, but generally, they correlate well (for example, the PMS5003 is said to correlate worse with particles coming from wildfire and better with other dusts and aerosols reference here).

Hope it helps!

Hi @pfhyper

A software fix for the light sensor issue has been released. You can read more about it on that threat:

Hope it helps!

1 Like

Does this apply to SCK 2.1 as well ?

It is specifically for version 2.1 :wink:

Ok - updated as per below. Still no LUX data :frowning:

hostname: SmartcitizenF8C2
mac: CE:50:E3:18:F8:C2
ESPversion: 0.9.0
ESPcommit: 0aee873
ESPbuilddate: 2019-05-06T20:27:10Z
SAMversion: 0.9.4
SAMcommit: a587fff
SAMbuilddate: 2019-06-27T12:56:50Z
updateNeeded: false

Hi Darryl,

I can see that you already connected to the kit console, there is a command called monitor that maybe can help us understand your problem:


So if in your console you type monitor light you will see a realtime monitoring of the light:

The third column are the light values obtained from the sensor, you can try pointing your kit to different sources of light to see how it reacts.

Keep us posted on your findings!

Hi Victor

I’m not sure why (as I’ve not investigated/made any changes) ,but it appears that it is functioning now (even though the values appear to be low). I’ll have a good look at it over the weekend and feedback…

regards,
Darryl