Back to

Persistent green light during onboarding

Ok thank you, are you trying to connect the smart citizen device with a computer or your phone?

Thanks, Lyndon.

I’ve tried both, none of them worked.

Hi @L.J.Ship

Any luck with it?

A persistent green blinking might indicate your Kit is in software update mode

We suggest you press the button for 15 seconds and after you do a full power reset by removing the battery and the USB cable. You can do a complete reboot with the Reset button, but the previous is even safer

Let us know if the problem persists

I tried to factory reset it but the problem persisted. Isn’t it weird that a password to log in the onboarding process is required?

Hi @doktorkampi,

My answer was for @L.J.Ship. Could you share a screenshot were it’s asking you for the password?

Thank you

Hello @pral2a

I tried holding the button for 15 and even 20 seconds and the green light continued to flash, then I disconnected the battery, but upon reconnecting it the green light began to flash again, I’m afraid. I received the SCK 2:1 kit intact and it appears to access the reset button would require dismantling the device, do you have any further suggestions?

Kind regards, Lyndon.

It happens before I can log in.

Sorry, could you detail more on your issue? Do you mean you have to type a password to connect to the SmartCitizen[…] Wi-Fi setup network?


That’s exactly what it happens. This way I cannot start the on-boarding process.
Any hints? I already factory-reset the kit and updated it as well.

It isn’t possible the SmartCitizen[…] Wi-Fi network is asking you for a password to connect to it. There’s no code implementation for that in firmware. Are you sure you are trying to connect to the right network? It looks above the network’s called SMA1930107624

Could you share a screenshot at the list of networks you see on your Android network page?


I see what’s happening… SMA1930107624 wasn’t de SmartCitizen network.

The led is red and slowly blinking, but I cannot see the SmartCitizen network. I factory reset it several times. When I push the main button, I get a fast-blinking green light.

It seemed that this could be a problem related to low-battery and I did connect to the SmartCitizen network but I think I entered the worng password of my WiFi network and it’s not working. Now that is constantly connected I cannot see the SmartCitizen’s network to start the onboarding process.

Any hints? Thanks!

Ok, now I’m totally lost. I followed instructions from but still I cannot see the network. I don’t know what happened some days ago, as it started to work for some hours and then it went down again. Is it possible that the kit is broken?

Thank you

Hi Looks like you have same problem as me, if expect some help here, better asking Santa, you will get faster response. Device stopped after storm

I finally get mine back working again but it’s still unstable.
Try remove Sensor Board and check if it’s connecting again. If yes, use a hair cooler to dry the pcb sensor and laser PM sensor. Reinstall and try.



I thought it was solved after our discussion. TL;DR, There could be a problem with your urban board (an indicator of it could be corrosion and blue powder near the sensors in the urban board).

To clarify, the normal behaviour is specified in the docs. Also, water issues are discussed here. If this is not helping, then some things to test:

  1. Disconnect all power (USB + battery). Disconnect Urban board too, and power it back via USB only. Wait until the kit wakes up and try to put the kit in setup mode:
  • If this step doesn’t work, there is a problem with the board that will be difficult to debug remotely. If you have an option to use the shell, we can see what the output is (paste it here)
  • If this works, move to next step.
  1. Disconnect all power (USB + battery). Connect Urban board, without PM sensor and power it back via USB. Wait until the kit wakes up and try to put the kit in setup mode.
  • If this step doesn’t work, probably the urban board needs to be fixed or replacement. You can try to dry it up with a hair blower. Look for signs of corrosion and see below for arrangement.
  • If this works, move to next step.
  1. Disconnect all power (USB + battery). Connect Urban board, and PM sensor, and power it back via USB only. Wait until the kit wakes up and try to put the kit in setup mode.
  • If this step doesn’t work, probably the PM sensor needs replacement. Same as above for arrangement.

Hope this helps. Please contact us (if you purchased it through us directly), or SEEED studio otherwise if the conclusions show that the sensors are damaged.


1 Like

Hi @oscgonfer,

It worked only for some time…

I tried to follow the steps you suggested and I got stuck in the very first one.

The message I receive when I use the shell is a repeating over and over:

Restarting ESP…
ESP off…
ESP on…
Restarting ESP…
ESP off…
ESP on…

Any hint?

Thanks a lot

Hi @doktorkampi,

Can you type this in the terminal?

shell -on

And then:


Then can you post the output here? We will send you an update accordingly.


Hardware Version: 2.1
SAM Hardware ID: 3DBDAA2C50515157382E3120FF0F1006
SAM version: 0.9.6-53fba6b
SAM build date: 2019-08-27T16:58:01Z
ESP MAC address: not synced
ESP version: not synced
ESP build date: not synced


Some extra things to try out:

  1. Connect the urban board to the kit and the pm sensor
  2. Open the shell again and type:
shell -on
  1. Then type:
  1. If the output to that is a list of sensors (Temperature, humidity…) Check that all of them are present.
  2. Then, one by one, try to
read <sensor>

Where <sensor> is temp, hum, pm 1, light… You don’t need to type the whole name. Each sensor from the list above should give you a reading. If not, there might be a problem. Be careful with the CCS811 (eco2 and vocs) because it will take 5 minutes to give valid readings.

If all that works:
6. Type the following:

config -mode sdcard

Give it 5-10 minutes and then check is there is data in the sd card for that day.

If all that works:
7. Type the following

config -mode network -wifi "<YOUR-SSID>" "<YOUR-PASSWORD>" -token <YOUR-TOKEN> 

Be careful with the “” in each keyword. The token can be anything at this moment (123456 works). The token doesn’t have “”.

Let us know!

All I get is “ERROR sensor not found” with every sensor I try.

And after that, “Restarting ESP, ESP off, ESP on” over and over again.

What is ESP?

Could the connexion between the to boards be broken?

Thanks a lot


The ESP is the chip that manages the communications (bottom-right corner in the pictures here).

It looks like there is an actual problem with the hardware. We will contact via PM/mail for more details.