Back to Smartcitizen.me

SCK 2 - Remote reboot

Hi guys,

Is it possible to remote reboot the devices, and save me dismantling the case or letting the battery discharge.

Thanks

Andy

Hi, Any!

There’s no way to reboots them remotely at the moment, but each SCK reboots automatically once a day to correct any hardware-software malfunction.

Would that work for you? Or do you want actually to switch to setup mode or perform a factory reset?

My device (https://smartcitizen.me/kits/9482) seems to be reporting, but the graphs dont seem to be updating, oddly battery levels are reporting correctly, but the others seems to be either flatlining or not showing and data, so I dont know if the issue is server side or device side.

I was hoping to force a hard reboot (similar to a battery disconnect) to see if that resolved any issues, before having to dismantle the case to get to the board.

I hope that makes sense

Andy

I had EXACTLY the same problem few weeks ago.
IDK how the kit has gotten into this state but after connecting to PC and debugging I found out that the temperature, pressure and other sensor are disabled.
Check this: Using the Shell
In the SCK prompt, execute sensor
And it gives you list of all sensors. And under Enabled you may see only Battery and maybe some others.
How to enable the others it’s in that guide.

but this is only with a local (usb) connection

seems to be reporting, but the graphs dont seem to be updating, oddly battery levels are reporting correctly, but the others seems to be either flatlining or not showing and data, so I dont know if the issue is server side or device side.

This behaviour usually happens when there is a problem in the Urban Sensor Board itself or the connection between this board and the Data Board. Sensors Boards and Auxiliary Sensors are automatically detected on boot so the Kit might not detect the Urban Sensor Board. Still, it will detect the battery, located in the Data Board, and only read and publish it.

I suggest you check the physical connection between the two board.

Hope it helps!

@bedinek really good point about trying to reenable the sensors via software after checking the hardware

This is exactly the section about enabling and disabling sensors using the shell

https://docs.smartcitizen.me/Guides/Using%20the%20Shell/#listmodify-the-active-sensors

Thanks for all the links,

Looks like i am back up and running

Just wanted to check, this is my current disabled/enabled list, does this look right or am I missing something for a standard 2.1 board?

Disabled

PM board Dallas Temperature
Direct Dallas Temperature
Ext Temperature
Ext Humidity
Temperature BME680
Humidity BME680
Noise dBC
Noise dBZ
Noise FFT
Gases Board 1A
Gases Board 1W
Gases Board 2A
Gases Board 2W
Gases Board 3A
Gases Board 3W
Gases Board Temperature
Gases Board Humidity
Groove ADC
INA219 Bus voltage
INA219 Shunt voltage
INA219 Current
INA219 Load voltage
DS18B20 Water temperature
Atlas Temperature
Atlas PH
Atlas Conductivity
Atlas Specific gravity
Atlas Dissolved Oxygen
Atlas DO Saturation
Soil Moisture Raw
Soil Moisture Percent
Soil Temperature
Soil Light
Ext Range Light
Ext Range Distance
Barometric pressure BME680
VOC Gas BME680
Ext PM 1.0
Ext PM 2.5
Ext PM 10.0
Ext PN 0.3
Ext PN 0.5
Ext PN 1.0
Ext PN 2.5
Ext PN 5.0
Ext PN 10.0
Ext PM_A 1.0
Ext PM_A 2.5
Ext PM_A 10.0
Ext PN_A 0.3
Ext PN_A 0.5
Ext PN_A 1.0
Ext PN_A 2.5
Ext PN_A 5.0
Ext PN_A 10.0
Ext PM_B 1.0
Ext PM_B 2.5
Ext PM_B 10.0
Ext PN_B 0.3
Ext PN_B 0.5
Ext PN_B 1.0
Ext PN_B 2.5
Ext PN_B 5.0
Ext PN_B 10.0
Groove OLED

Enabled

Temperature (60 sec)
Humidity (60 sec)
Battery (60 sec)
Battery voltage (60 sec)
SDcard present (60 sec)
Light (60 sec)
Noise dBA (60 sec)
Altitude (60 sec)
Barometric pressure (60 sec)
Pressure internal temperature (60 sec)
VOC Gas CCS811 (60 sec)
eCO2 Gas CCS811 (60 sec)
PM 1.0 (60 sec)
PM 2.5 (60 sec)
PM 10.0 (60 sec)
PN 0.3 (60 sec)
PN 0.5 (60 sec)
PN 1.0 (60 sec)
PN 2.5 (60 sec)
PN 5.0 (60 sec)
PN 10.0 (60 sec)