Back to Smartcitizen.me

Temp & Humidity sensor have spike data read


#1

I’m run SCK 1.1 about two day. I found sometime the sensor read the incorrect value. It show above 130 degree. Please see my data below. And is it possible to do a calibration on this sensor? The temperature look lower than it should be.

(http://www.smartcitizen.me/devices/view/796)


#2

Hi mangsab! The overshoots in temperature/humidity is a know issue. We are already working on it. Hopefully, it will be fixed for next week. These temperature/humidity readings are sent in RAW to the platform where the algorithms are applied. It seems like sometimes it does the maths wrong.
Work in progress! :slight_smile:


#3

Hi aitoraloa, I see my spike data gone from graph. I think you do some change on coding. But both Temp/Humidity show the same value.

And what about sensor calibration? This morning i’m got 28 celsius on digital thermometer but on SCK it read only 22.6 celsius. Its alway lower than normal temperature (About 5 celsius)


#4

Hi mangsab! When we were correcting the spike data error, a variable was repeated in code and this is the reason why during yesterday, the temp/hum readings were showing the same value. It is already solved! :slight_smile: The temperature sensor reads normally 2 to 4 degrees less than the actual temperature value. The algorithm needs to be reformulated. I will let you know as soon as this is fixed… Best! :wink:


#5

Thank you aitoraloa. I will wait until the fix come.


#6

Any update on reading temperature value problem?


#7

Not yet. We will let you know. Dealing with a bigger problem right now. :slight_smile:


#8

so, I just received my kit and ran in to several issues. I’ll post in the relevant topics. Regarding Temp and Humidity, the graph on the website shows my values stuck at 100% rh and 50 deg C with no variation at all. Is this a bug that still needs to be sorted out ?
The serial data coming from the SmartCitizen is :


Temperature: 028964 C RAW
Humidity: 32760 % RAW
Light: 00000967 lx
Battery: 100.0 %
Solar Panel: 00000000 V
Carbon Monxide: 0000308757 kOhm
Nitrogen Dioxide: 22.133 kOhm
Noise: 00000363 mV
Wifi Spots: 1
UTC: 2014-4-14 8:06:26


SmartCitizen Device link :

Anool
Mumbai, India


#9

For the calculation of temperature and humidity.


#10

Like Anool - same with me. Got mine today and it also reads 100% humidity and 50 deg C


#11

Same here: http://smartcitizen.me/devices/view/1039


#12

so this definitely looks like a bug. Are the Dev’s looking in to this ?

Anool
team @wyolum
Mumbai, India


#13

Hello all,

we just found a bug in our data calibration system when dealing with batch updates.

Now it is solved and everything should be working fine.

Our apologies and please let us know if something goes wrong again,

your feedback is really appreciated.

Guillem.


#14

No, it still doesn’t work.


#15

And it seems website not really works as well as it should :frowning:


#16

Got mine today, but it also reads 100% humidity and 50 degrees Celsius (although it’s 10 degrees outside). Hardware failure or software bug?


#17

It should be fixed now, @guillem @alex did you check this ones? It seems to be a website bug

Tomas


#18

Hello all again,

we just found a bug on the latest firmware release (v0.8.6) in Github which was causing the issue. This has nothing to do with the previous fix and it should had affected also those users who manually updated the firmware to the latest version during last week.

We solved the bug on the platform side so you do not even need to manually update the firmware again. Anyway you can check the latest release with the bug fixed in GitHub.

Our apologies for the inconvenience,

Guillem.


#19

Looks like it’s fixed after you guys did the latest bug fix. Now, we need to get the sensors calibrated. My current temp on SCK shows 27 dec C , but it’s actually 33 deg Indoors (36 deg in the sun) and humidity on SCK is 63% rh , but it’s actually below 35% rh.


#20

fix confirmed. since this morning, about 8 o’clock GMT I get correct readings.

Thanks :slight_smile: