Back to Smartcitizen.me

Temperature and Humidity wrong values


#1

Hi,

I have just upgraded to the latest version of the firmware and I have solved the connectivity problem I had.
However, I get obviously wrong values from some of the sensors, 50C for the temperature and 100% for the humidity.
The kit is indoor.
Solutions?
Thanks.


#2

Hi cdelrosso,

I have the same problems, but thinks this thread might explain:

http://forum.smartcitizen.me/discussion/comment/490#Comment_490

last comment is explanatory I think :slight_smile:


aitoraloa March 17
Not yet. We will let you know. Dealing with a bigger problem right now. :slight_smile:


#3

Hi, what can I write the serial port?, Is a different error is written in the other thread.


#4

Sorry mdeheras,

I do not fully understand your question?


#5

Open Arduino IDE serial terminal, like leaves in this tutorial and tell me what it shows.


#6

ah, you can find the output I see in this thread:

http://forum.smartcitizen.me/discussion/373/nodata-received-yet#Item_8

although I do wonder if all the output is valid, it works.


#7

You can put your data serial @cdelrosso


#8

I have the same problem, will this need a firmware upgrade?


#9

I setup readings every 5 minutes and reporting every hour and I get the same problem. The bad temp/humidity is present when the SCK does not report every time.


#10

not much activity on the forum… You guys still working on this?


#11

Hi @menendez! Please, would you mind to share your SCK’s url with us in order to see that temperature and humidity wrong values you are talking about!? Best. :slight_smile:


#12

Hi

I received my kit this morning, installed it and connected it.
Now i receive some data, but I got this temperature / humidity problem.

My serial is the following :


Temperature: 26952 C RAW
Humidity: 21300 % RAW
Light: 369.7 lx
Battery: 90.7 %
Solar Panel: 0 V
Carbon Monxide: 373.845 kOhm
Nitrogen Dioxide: 11.097 kOhm
Noise: 0 mV
Wifi Spots: 8
UTC: 2014-4-12 9:08:47


You can see on my device : http://www.smartcitizen.me/devices/view/1065
I always have 50°C and 100% humidity

How can i fix it ?
Is this a bug ?

Thank you


#13

Hello Yaug

this looks strange. You did the last update of the firmware? Can you please do it again, all the registration process? We want to make sure you have latest version, we will check in our database to see if it is a mistake of the data conversion. If they are not the problems, we will change your sensor board.

Thanks for reporting

Tomas


#14

OK, I 'll do it again this afternoon.

But as i followed the tutorials, I think I had the last firmware (or I should a different tutorial ?)


#15

If it is the case, then maybe is a hardware issue, but sometimes re-flashing memory fixes some bugs, lets try. I will also check our data base

thanks!


#16

There it is http://smartcitizen.me/devices/view/1039
I verified the problem occurred over night with 5 minutes reading reporting every hour. I just changed it to 1 hour reading reporting every hour to avoid the bug


#17

I just updated to the latest develop branch and set it back to 5min/1h to see if the latest commits fix this


#18

same problem


#19

sorry to post in multiple threads. I seem to be having the same problem of 100% rh and 50 deg C. I posted about it here : http://forum.smartcitizen.me/discussion/302/temp-humidity-sensor-have-spike-data-read-#Item_9

What seems to be the problem. My device URL is :

Anool
team @wyolum
Mumbai, India


#20

Hello all,

we just found a bug in our data calibration system when dealing with batch updates.

Now it is solved and everything should be working fine.

Our apologies and please let us know if something goes wrong again, your feedback is really appreciated.

Guillem.