Back to Smartcitizen.me

USB port fell of the board at reception of the SCK


#1

Hello,

I am happy to receive my smartcitizen kit (from the kickstarter campaign). Unfortunately the USB port just fell of the board when I was checking the board. On further inspection the USB port as five tiny connector which does not seems to be solder to the board and two larger thingy on both side of the port which seems to be glued or solder to the board. As far as I understand, the port connection on the board is using SMD.

How do I reattach the USB port ?


#2

A photo of the board without the USB port :
https://o.xvc0.net/public.php?service=files&t=73235dfd8b3998ce03af14220feecf44

/me is sad.


#3

Hi aegiap,

I hope you had a good start of the week despite the USB collapse. :slight_smile:

This problem is already known. We have personally suffered the frustration of watching the USB detached from the board. Seems like the solder pads in the USB are not strong enough in some boards (not to say extremely weak) and they can not stand any kind of strength.

Although we think that this should not happen if the solder is properly done, we also have to admit that a through-hole USB connector would have been a better idea. We have already change this detail for the next revisión of the board.

Anyway, we are already working on a little step-by-step manual to show how this can be fixed. It is really easy. You just need a soldering iron with a thin tip and strong glue. Hopefully, it will be available for the weekend.

If you have any further questions, please do not hesitate to ask.

And sorry for any inconvenience this may cause you.

All the best,
Aitor.


#4

Aitor,
Do you have any idea when the tutorial will be ready?


#5

#6

Thank you for the tutorial but soldering each pin of the micro-USB port could be really tricky for inexperienced solder like me.

I think I will try this flow and whick solution which seems less painfull:


#7

I wonder that super glue is strong enough?


#8

Mine just came off too :frowning:


#9

Hi Guys!

@Cie: sorry to read that! :frowning: Let me know if I can do anything for you.

@mangsab: superglue works but make sure the USB connector is always treated with care. You can also add some extra super adhesive to the mix (i.e. epoxy glue, sugru,…). We have not used them yet. Please, let us know if you try. Pictures are welcome! :wink:


#10

I try to fix the miniUSB by soldering it to the board after reading the tutorial but the soldering is really tricky as the shield of the USB port does not give a lot of room for the tip of the solder iron. I ask a couple of people to help in the soldering without success at the moment.

Do you plan to sell only the board with the arduino and the USB port ? I understand the board as the wifi module, so it may be a bit pricy. In another post [1], you recommend to wait to further stock, how can I subscribe to get the notification of availability ?

[1] : http://forum.smartcitizen.me/discussion/comment/531#Comment_531


#11

@aegiap: Yes. You are right it is a bit tricky but with the right tools it is really doable. I love the video you shared. Flow and wick solution works often really well but I guess it is not the best option in this case. :slight_smile: We will have the only-board option available too in the near future but the estimated delivery time for the arrival of the next batch is 8 weeks. Best. :wink:


#12

I ended up having issue remounting it as well (and the pads were shot).

I ended up sacrificing a USB cable and hard wiring it to the board. When not in use, I tucked it between the board and used a thumb drive cap over the end to make sure it didn’t short anything out.


#13

I had the same problem, but after soldering it back on it came off again this time taking the pads with it. It’s pretty much beyond repair now. Is there any plan to replace the defective boards?


#14

This is how I wired mine up. It works in a pinch, http://imgur.com/xZGX0e1 but I’m still up for a replacement board as well.


#15

Thanks! I’ll try it. Can’t be worse than having a $150 paper weight.


#16

Does the 5th pad go to anything?


#17

Nice hack @CKCKCKCK1! :wink:

@DrStrangebeast: sorry to hear that. Please, try CKCKCKCK1’s hack and let us know if it worked. Meanwhile I will see what I can do about the replacement. There is just one pad not connected to anything but it would be the 4th, not the 5th. You can see an schema of the USB here: http://sigmakey.com/nfs/content/6105/file/Fly_Q420_E176_Huawei_G7010-G6150-pinout_MINI.jpg Note that this is an image of the cable, not he connector. Pin number 1 is Vcc (or Vusb). Let me know if you need more info, please. All the best.


#18

The hack worked for now, but any tension on the cable is enough to snap the wires off again (already happened twice). I think the only permanent solution would be a properly mounted through hole USB port.


#19

I also done the same way. https://dl.dropboxusercontent.com/u/2182071/2014-03-21%2007.57.17.jpg

Like DrStrangebeast said. It not strong enough and need a through hole USB port. And I also replace the WiFi module because it not response to any command. It came from boot file on module is damage from something.

The usb port is not recognised on windows but work on Mac OS (not 100%).


#20

yes, definitely! The new rev of the board will have a through hole USB connector. :slight_smile: