Back to Smartcitizen.me

Well it worked for about 24 hours


#1

Hi guys,

this is disappointing. I had everything hooked up (device + solar). I charged the battery full - and put it outside at night. In the morning charge was down to about 65%

Problem 1: Solar charge - started out fine - charge climbing from 65% upwards. But then suddenly showed 100% charged - then a few minutes later - the real charge - then a few minutes later again - 100% - and so it cycled. In 4 1/2 hours it only managed to reach a charge of 82% - so from 65 -> 82% = 17% which would be equal to about 350 mA? of charge put into the 2000mA battery. - So charge algorithm is defiantly off - or charge circuit is not working.

Problem 2: board wifi -> access point dead…
Well as you might guess - 82% was not enough power to keep it running overnight. So it died in the early hours in the morning. After which - at first light - it woke up again - but once sun hit the panel (not just indirect light) - SLAM - something went wrong - and device no longer connects to any access points - and there is now a high pitched “whine” (sounds like capacitor whine) coming from the board. I have tried updating firmware - I have reset config from website. I have manually tried to add my access points to the wifi-board - and nothing helps.

Guys - I think this hardware is not tested with solar panels - or at least not 18v/10watt solar panels.

My board is now unusable - apart from with direct USB connection - but that does not give me any help does it?

I don’t really feel like debugging your hardware as I would have to download Eagle. But maybe if you post a pdf of your schematic I could figure out what is wrong.


#2

Hello Kaz,

thanks for the feedback.

P1.

This seems to be an issue from the charging current limiter. You’ll see on the firmware the function sckWriteCharge(350) which limits the charging to 350mA to prevent drawing to much power from the USB port on laptops. We will work on adding solar power detection and implementing a quick charge mode (500mA) in this case. At the same time you have to realize that the battery charging is not linear, it always starts charging at the maximum current but it switches to voltage limitation when battery is close to be charged. The charging algorithm to provide you feedback it’s based on voltage and that’s why it can show 100% when the battery voltage it’s achieved but still needs some time to get its full current load. Of course we would work on a better algorithm approach in a future, any suggestions are welcome.

P2.

We will try to replicate this tests in our lab using the same specs your panel has. The charging circuit is a good tested design based around the LM2674. Unless the input voltage is bigger than 25V or some short in the panel occurs it is difficult to brake it. Are you sure your panel wasn’t providing more than 25V?

Anyway we’ll do some research on the upcoming days and I let you know more about it.

Thanks again for your detailed explanation.

Guillem.


#3

Hi,

the panel is the one supplied by you guys. It has a Voc of 21.6 volt. I am an EE :slight_smile: and have plenty of solar panel experience. While Panel was charging - it would show 22.6? volt from time to time - so above Voc - but I guess that might be due to resistor tolerances. The entire setup was sitting the same place with no movement all throughout the day/night where it worked.

I know battery charge is not linear - but a LiPo battery should be able to stay on full charge until at least 85-89%

Anyway - my hardware is dead - or at least - it is not connecting to wifi any longer.

And another question: Which battery fits the RTC clock battery holder?


#4

one more thing - in your lab test remember to use a depleted battery. :slight_smile:


#5

We do not include the solar panel, I must have sold Acrobotic, we have always recommended a panel of 12V and 500mA. The RTC battery is CR1220.


#6

It is the panel supplied to the kickstarter backers.

Anyway - I noticed that when charging - your charge controller keeps the panel voltage down @ around 5 volt. That should not really happen?

Anyway - if all kickstarter backers uses the 17v nominal panel - I guess the people running the kickstarter campaign has the world of hurt in front of them.


#7

glad I saw this before I hooked up my Panel… Is there a resistor I can put in line to help solve this or is the Panel just junk for this use? I mean not that I have gotten it to register and or work yet…


#8

I’m going through the schematics at the moment - just waiting for eagle to finish installing. Response from the " project " owners seems non existent.

I think when battery is completely flat - and charge starts at 22v - there is a voltage spike that took out my WiFi module - or part of it anyway.

But the panel is rated at 17.5v - and board currently max " consumption " incl charge is 350 ma. So battery charge is only 250 ma as board with current software uses about 100ma. So that is 115-120 ma @17.5v - or < 25% of the panel possible current.


#9

If I’m not wrong - the Vin (from Panel) goes though a diode - then to a 20k/10k voltage divider -> ground. The 1/3 voltage goes to PB4 (P_LEVEL ADC) on the Atmel - used to measure panel input voltage.

So about 1/3 of the Vin voltage is presented at the PB4. But the ATMEGA has a maximum ADC input voltage of 1 x Vcc (5v) - so maximum panel input voltage should not exceed 3 x Vcc + Diode Drop = so in round figures maximum input voltage would be about 15 volt plus a bit.


#10

Know the limitations of the analog input, so a panel recommended 12V, but whatever Acrobotic sold 18v panels. There is a limitation to 100mA when battery is fully discharged, but when returns to normal operation up to 350mA.


#11

Checking this between Acrobotic and Smart Citizen, will respond accordingly to the issue. Many apologies, running a collaborative and open project with such ambition can cause this issues, please keep throwing us more of those. Also will look to replace broken units and will come with solutions! again apologies guys, has been a complex development but it will not stop here, will take all the inputs and improve, and try to fix cases in which we caused many trouble. We kindly ask so partnership from your end, which you are doing right the way…


#12

Can the existing solar panel be “hacked” to provide limited voltage to the board? I.e. can we tape off / darken a number of the solar cells to reduce the voltage output of the board to a safe level? Or will you be sending out a different panel / hardware to compensate for the solar panel? Assume we should wait on hooking up the solar panel for now…


#13

I have the same problem with my board (Kickstarter with solar panel and battery). It works for 2-3 days and now no connection to any access points. Both blue LED’s blinks on the board.


#14

Same problem here with the Kickstarter kit with solar panel, device ID 821.

It was working for almost 2 days - although only ~12 hours on the battery before it needed recharging, not the 2-3 days mentioned elsewhere. Now, when I try to recharge it, all I see is the two blue lights flashing alternately on the board, as others have described.

I guess the board tried to rely on the solar panel today when the battery ran out.

Each time it tries to send a report now, the serial port prints out an error saying ‘Error in connectionn!!’


#15

Remove the battery and put it back.


#16

I’ve given that a try, but I’m still getting the ‘Error in connection!!’ message


#17

Same problem again.
And now my battery cable is broken on the connector.


#18

Any other suggestions for getting this to work again? It’s a disappointing start :frowning:


#19

I’ve tried updating the board with fresh firmware and configuring it from there, but it’s still not working.

The board is showing wifi networks if I type ‘scan’, but isn’t connecting to my network. If I type ‘get i’, I get the following details:

IF=UP
DHCP=ON
IP=0.0.0.0:2000
NM=255.255.255.0
GW=0.0.0.0
HOST=0.0.0.0:2000
PROTO=TCP,TCP_CLIENT,
MTU=1524
FLAGS=0x7
TCPMODE=0x0
BACKUP=0.0.0.0


#20

Access the terminal mode and type “factory RESET”, “save” and “reboot”, then reconfigure the module.