Back to Smartcitizen.me

Well it worked for about 24 hours


#41

Hi guys! :slight_smile: You can try to use this registration/firmware update process from our sandbox: http://sandbox.smartcitizen.me It is still beta, but solves most of the know issues with platforms and browsers. Let us know how it goes, this is not an official release yet. Thank you! Best.


#42

Tried the sandbox - and that did not recover the WiFLy module.


#43

Kaz

can you confirm that the whole process was done correctly? If your module is not responding we will do the possible to replace it, but we need to confirm 100% please.

Tomas


#44

Hi Tomas,

i got a defective module from Cicso I can “butcher” but I would rather get the firmware flying. Do you have any other recovery options on how to upload firmware apart from via the webpage?

But yes so far neither chrome or firefox updates anything - not even the firmware on the card. It talks to the card for a micro second and then stops. A normal arduino software upload flickers the yellow leds for 5+ seconds.


#45

Kaz911, same behavior here.

Tomas, can we get to it via the ICSP port?


#46

nothing is working here as well, sandbox no connection
problems for more the 2 week now
my main problem is the bad communication, please put clear working instructions on here how to download the beta firmware etc.
this is really annoying!
i was planning to make a positive blog, but is getting very hard now!


#47

I would prefer a replacement, but would settle for a refund as well. I’ve had a $200 paperweight which I struggled to justify cost on from the start.


#48

Hi @bwired, @wakeforest, did you try the new registration process? We do not have the documentation of the ICSP upload ready yet. WE have alternative firmware upload here: http://smartcitizen.me/topics/view/3

I know it could be frustrating, and we are trying to fix all the possible problems you are having. All your feedback help us to improve all the pieces of the project. We have not been developing a final product, but a platform which is extendable and hackable. We want to make this point very clear.

Let us know how it goes, and we will try to find the solution together

Tomas


#49

I’m also a little bit confused.
I’ve the same issue as CKCKCKCK1 and also the same outputs he has. I’ve tried all the possible solutions but my SCK is still not working. I’ve tried the new set-up from sandbox, the old one from the smartcitizen main page (with Chrome ans Safari) and both are finishing telling me to reset the SCK to finish the setup. I’ve loaded via IDE the different sketches from 0.85 and 0.86 (wifly rescue, wifly update, etc.etc) and the load process is working fine but the SCK still blinking the 2 blue leds and not sending any data. With the Arduino IDE I allways see only the web_app outputs on the serial line.
Somehow the wifli module is not updated.

What can I try now?
I’ve built a “follow the sun” system for the solar pannel to maximize the loading of the battery and I would like to have my SCK connected and finally sending data!!

Stefano


#50

Hi Stefano

it was working before? did you use it with the solar panel and then somehow stop working? If not, you should try the new process in Chrome, in the current platform. Then we should look if you are doing all the resets that the process is asking you

Finally can you try changing WPA2 and WPA networks, or if you are using spaces make sure you put a $ instead?

Send us what you see in the serial

thanks

Tomas


#51

Hi Tomas,
yes it was working before and I used it with the received solar panel.
I’ve now downloaded sck 0.86 and when downloading the IDE show me the warning:

Sketch uses 28,324 bytes (98%) of program storage space. Maximum is 28,672 bytes.
Global variables use 2,409 bytes (94%) of dynamic memory, leaving 151 bytes for local variables. Maximum is 2,560 bytes.
Low memory available, stability problems may occur

In the serial output I see nothing (empty window) and nothing happens.
If I set

#define wiflyEnabled false

in the Serial outpu window I see some sensor data:

Temperature: 27388 C RAW
Humidity: 22576 % RAW
Light: 165.0 lx
Battery: 100.0 %
Solar Panel: 0 V
Carbon Monxide: 262.185 kOhm
Nitrogen Dioxide: 22.500 kOhm
Noise: 122 mV
Wifi Spots: 0
UTC: 2000-01-01 00:20:56


If I enable debugging with

#define debuggEnabled true

I see following serial output:

Resetting…
4 MySSID MyPassword 0
SCK Sleeping…
SCK Waking up…
4 MySSID MyPassword 0
updates = 1
Error in connectionn!!
SCK Sleeping


Temperature: 27460 C RAW
Humidity: 22292 % RAW
Light: 168.5 lx
Battery: 100.0 %
Solar Panel: 0 V
Carbon Monxide: 268.371 kOhm
Nitrogen Dioxide: 22.774 kOhm
Noise: 96 mV
Wifi Spots: 5
UTC: 2000-01-01 00:37:29


… and then it starts again.

When I load the sketch Wifly_Rescue I see following serial output:

Reseting…
Successfully reset
WEB_APP-1.06>
<WEB_APP-1.06>

and then I can enter the web_app commands, i.e.

<WEB_APP-1.06> ls

FL# SIZ FLAGS
2 86328 23 wifly-GSX-400
4 74920 3 web_app-GSX-106
7 46632 3 wps_app-GSX-131
9 66240 3 eap_app-GSX-101
11 37282 0 web_config.html
21 512 0 link.html
22 7268 0 logo.png
24 -1 10 config

169 Free, Boot=2, Backup=2

Going back to the sketch sck_beta_v0_8_6 I’ve the same output as before.
The 2 blue led are always blinking.

Some ideas?

Stefano


#52

Same result here, costing me many hours now, but still no upload!


#53

The topic already has an answer? I’m having the same problem !!! :frowning:


#54

I noticed something strange today. When the sck is waking up, the internet connection from my wireless router (also used by sck) falls. The wireless router resumes after the error message on the connection.

Two questions arise:

  1. The WiFly is using data from my wireles router network to himself become acess point (AP Soft) and also with the same settings as my wireless router?
  2. The WiFly radio is using some routine that disrupts the signal around him?

Kind Regards,