Back to

Where to buy SCK 2.0?

I got my device this morning.

I have setup and connected :smiley: but seems like a few of the sensors are reading some odd values. Device is currently inside and reading 0degC for temp (thermostat states about 21degC. Also lux is reading 0.

Hopefully will be able to get this sorted.

Hi @smartcitizen1,

We are sorry about the issue. All the Kits go under a validation process we designed, and SEEED runs on every Kit they ship.

I will ask SEEED and come back to you soon.

For the moment I will suggest you reboot your kit and you check after if the issue persists.

Thank you

Hi @smartcitizen1

Is this the kit you install with issues?

Thank you

Kit arrived today, very fast shipping from Shenzen. Nice!

Even nicer: kit is up and running in no time and already pushing data to the net. Kudos except for the delay. It was well worth the wait. Keep up the good work! - Jos Gysenbergs, Belgium

Thanks for the feedback!

Please, post any issues, comments and questions here.

We are collecting them to improve the documentation.

We are also working on a new enclosure.

Hi Pral2a,

Yes, I have been running the unit for about 2 weeks now - Kit name on map sausage_monitor.

Lux sensor is normally 0 (even with light on). Temperature has been about -1.6 most of the time. It did hit 26degC on the 2nd June, but then dropped back down.

Is there a way of connecting to the device and seeing raw data, or even re-calibrating the unit.



It looks like there is a hardware issue with your device! I just checked the factory test report for your device and temperature looked fine.

Monday is bank holidays here in Barcelona, but on Tuesday we’ll discuss your problem with @victor who leads the firmware development. We’ll check if it can be a software issue, which might require you to update the firmware, or maybe it is a hardware issue and SEEED needs to replace your device.

We’ll write you back soon!

1 Like

thanks pral2a, I will await yours and @victor 's response and troubleshooting tips


I had the same issue (0 light data). I think it’s a PSU problem. Light measurement became solid after upgrading the power supply to a 10W version, that seemed sufficient for powering the two boards plus Plantower dust sensor while charging the li-ion battery at the same time.

Which tracking site you were using to track the package? Because i’m unable to locate the package based on the seeed studio tracking id.

Hi @jgysenbergs

Your comment sounds interesting! We’ll try to replicate the issue tomorrow and write you back here!

I used the 17track app on my phone. Or you can try on a desk/laptop.

For anyone having issues tracking their orders you can also write to

Tried using it too, but it is unable to detect sender, tried going thru all the usual suspects, but no luck.

Will try to write to seeedstudio, maybe they sent the wrong tracking number.

One more thing: shipping was unusually fast compared to e.g. AliExpress. Mine went from Shenzen to London Heathrow in two to three days and then to Belgium. All in all one week from China to Europe. That’s quite fast. Also, I did mail Seeedstudio and they responded with two tracking numbers which both produced the same tracking info from 17track.

Thanks for sharing your experience!

We are working with SEEED distributors network to sail directly from Europe and the US. That will reduce shipping times and more critical, CO2 emissions!

In my case Seeed used 4PX carrier in China and then Royal Mail from UK to Belgium. Quite fast.

1 Like

Hi, since a few days I have the Smart Kit running. The Lux sensor suddenly stops measuring or doesn’t measure at all. The rest seems ok. I hope it can be fixed.
Thanks & best regards,

Hi @ruud.raats

We’re looking at your issue. Could you share us the URL of your Kit?

Thank you